Linux Client — webdav - server replied: forbidden

client
webdav_issue

#1

Expected behaviour

After a reinstalled owncloud on my RaspberryPi3, I tried to connect my Linux Desktop Client with my RasPi, by inserting my login information into the Client.

Actual behaviour

My Owncloud can be accessed in my Browser (and on a Desktop Client on a different PC), and the Desktop Client on this first PC finds the Server, but after inserting my login information into the Client, the Client says

Error transferring https:// raspberrypiaddress/remote.php/webdav/ - server replied: Forbidden

No idea what that means, no idea what to do; I already googled a bit, what I don’t really seem to have a specific answer

Steps to reproduce

  1. Freshly installed Owncloud on my RasPi as described here: pimylifeup. com/raspberry-pi-owncloud/
  2. re-installed the Owncloud Client on Debian as described here: at the offical meantioned opensuse page (but I already had the error before that)
  3. tried to connect to my RasPi via the Client

Server configuration

Operating system: Raspbian Stretch, Version October 2018 (release: 2018-10-09)

Web server: ?

Database: ?

PHP version: php7.0

ownCloud version: Tarball, production, 10.0.10, 2018/09/18

Storage backend (external storage):

Client configuration

Client version: production, 2.5.0, 2018/09/18

Operating system: Debian GNU/Linux 9 (strech) 64-bit with GNOME V3.22.2

OS language: ?

Qt version used by client package (Linux only, see also Settings dialog): ?

Client package (From ownCloud or distro) (Linux only): according to the Settings-Page: 2.2.4+dfsg-2

Installation path of client: default(?)

Logs

  1. Client logfile: https://paste.ofcode.org/398u46XMDZPs3wDnWkbcQS2

  2. Web server error log: https://paste.ofcode.org/NfjQ2z4vcq8eXuCKcMnCkw

  3. Server logfile: ownCloud log:
    {“reqId”:“pJESnLkSi1sa29HHTT7J”,“level”:3,“time”:“2018-11-06T18:07:19+00:00”,“remoteAddr”:“192.168.178.28”,“user”:"–",“app”:“no app in context”,“method”:“POST”,“url”:"/apps/files/index.php",“message”:"User backend OC\User\Database is returning home: /media/ownclouddrive/Luke00126 for user: Luke00126 which differs from existing value: "}


#2

Exactly the same behavior after the owncloud update, done from owncloud itself.

Server on Cubieboard w/ Debian Cubian (stretch)

Client on Debian 9.2 / AMD64 laptop.

Complexity of friendly system seems to prevail always …


#3

@calamarim Hey, it looks to me that you have done an update where @HazieHurst did a reinstallation.

As long as @HazieHurst havn’t done a reinstallation to a newer version those sounds to me like different issues (but with the same outcome) so i think you probably should better create a fresh topic.