Local storage option missing (and 2 other side questions)


#1

Im very new to own cloud and really just had a few questions (not really trying to submit a bug here). Hopefully this is in the right section/area.

I finally got owncloud working but I’m not able to configure local storage. Im trying to include my shareroot folder into my owncloud server but “local” is not an option in the drop down as specified here: <removed link due to error on save, even though this is an edit>/local.html

How do i include a local folder (/mnt/usb1/shareroot) for access within my owncloud?


Other Misc questions, can be ignored if disturbing

I created an account with xyw@swe.com but when i go to Server>Personal>Settings and try to enter xyw@swe.com for the email i get: Invalid mail address . Why cannot i link my server to my account?

the root of my web server has a redirect (I’m working to get rid of the redirect but for now its there). After installing the owncloud client on my windows machine it ask for the server address. However it automatically removes index . php. Because of the redirect i need it specifically reference the service: /index.php . is there any way around this for the client configuration or i need to get rid of the redirect?


Steps to reproduce

1.load main page
2.then go to admin>storage
3.click the drop down for “External Storage” and notice “Local” is not there

Expected behaviour

“local” option should be available

Actual behaviour

“Local” is missing, cannot configure locally accessible directory

Server configuration

Operating system:
OpenWRT

Web server:
lighttpd

Database:
whatever is default probably sqlite

PHP version:
7.2.8-1

ownCloud version: (see ownCloud admin page)
10.0.9.5

Updated from an older ownCloud or fresh install:
fresh install

Where did you install ownCloud from:
downloaded latest tar from your site

Signing status (ownCloud 9.0 and above):
i dont know/doubt it

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

No errors have been found.

The content of config/config.php:

<?php $CONFIG = array (b 'trusted_domains' => array ( 0 => '192.168.1.1', ), 'datadirectory' => '/www/owncloud/data', 'overwrite.cli.url' => 'http://192.168.1.1', 'dbtype' => 'sqlite3', 'version' => '10.0.9.5', 'logtimezone' => 'UTC', 'installed' => true, ); ``` Log in to the web-UI with an administrator account and click on 'admin' -> 'Generate Config Report' -> 'Download ownCloud config report' This report includes the config.php settings, the list of activated apps and other details in a well sanitized form. or If you have access to your command line run e.g.: sudo -u www-data php occ config:list system from within your ownCloud installation folder *ATTENTION:* Do not post your config.php file in public as is. Please use one of the above methods whenever possible. Both, the generated reports from the web-ui and from occ config:list consistently remove sensitive data. You still may want to review the report before sending. If done manually then it is critical for your own privacy to dilligently remove *all* host names, passwords, usernames, salts and other credentials before posting. You should assume that attackers find such information and will use them against your systems. ``` **List of activated apps:** ``` If you have access to your command line run e.g.: sudo -u www-data php occ app:list from within your ownCloud installation folder. ``` **Are you using external storage, if yes which one:** local/smb/sftp/... trying to use local **Are you using encryption:** yes/no no **Are you using an external user-backend, if yes which one:** LDAP/ActiveDirectory/Webdav/... idk/no ### Client configuration **Browser:** none configured yet **Operating system:** n/a ### Logs - let me know if needed ill include later

#2

Read until the very end of that page - local is disabled by default. You need to enable it via the documented config switch.