Login Problem, using version 10 (downloaded from official site)


#1

Steps to reproduce

  1. Start Owncloud server;
  2. Enter URL into browser (using Chrome);
  3. Execute attempted login.

Expected behaviour

Tell us what should happen

Successful login into my account.

Actual behaviour

Tell us what happens instead

I had no difficulty logging in earlier after I initially installed Owncloud. Note: I’m using VMWare workstation as host. The trouble began after I installed a few applications, actually 4 in total, and a few plugins/extensions. In addition, the desktop client has never
worked for me in login attempts. The area where the url is has turned bright red.

Server configuration

Operating system:

Windows 10 64 bit

Web server:

Using VMWare Workstation 12

Database:

Virtualized

PHP version:

Virtualized

ownCloud version: (see ownCloud admin page)

10 (latest)

Updated from an older ownCloud or fresh install:

No, fresh installation.

Where did you install ownCloud from:

The official website, nothing third-party.

Signing status (ownCloud 9.0 and above):

Administrator

Login as admin user into your ownCloud and access 
http://example.com/index.php/settings/integrity/failed 
paste the results into https://gist.github.com/ and puth the link here.

The content of config/config.php:

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.

or 

If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

Don’t remember exactly, but they were typical for file transfers with client accessibility. Also, tried the command line to get a listing of the applications. Response was “failure to open”.

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

N/A

Are you using encryption: yes/no

No.

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

No.

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM oc_appconfig WHERE appid = ‘user_ldap’;

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.


### Client configuration
**Browser:**

**Operating system:**

### Logs
#### Web server error log

Insert your webserver log here


#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here


#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) …

Finally, this isn't a matter of grave importance. I'm using ownCloud for personal projects. I also haven't lost any data, I'm just not able to login to my account.

Christopher

#2

We’ll need logs and the list of applications in your ownCloud.

There isn’t enough information to reproduce your problem or to figure out what’s happening.


#3

That’s very vague. “A few apps”, a “few plugins”…“The area has turned red.”

If you changed the configuration of your server, for example installed two factor authentication and mis-configured it, or enabled encryption and made a mistake during setup - your ownCloud might have an issue with that. But that are just guesses for me.

@jvillafanez said it already, without more information I doubt that someone could help you.