Login to cloud works everywhere but linux application

help

#1

Hi there everyone!

I've installed the Owncloud script on my server. I can successfully log into the owncloud system via browser, on my Android phone and via the Windows app.

The problem, however is in my Debian install. I installed the app and upon startup. it asks for my server address, which I enter. The wheel spins, a green lock shows up and it asks me for my login credentials. I enter them and it returns "Error: Wrong credentials."

I've tried copying and pasting from a text editor to ensure I'm typing the password correct but it all results in this error. These same credentials do successfully log me in on every other platform, it's just the app on my Debian install that is giving me this error.

How might I resolve this issue?

Thanks for your time!


#2

I've done a bit more playing around. If I try to log in with a bogus account, I get an entry in the log file:

{"reqId":"5nLCZB5Ro0sB9eMhb75E","level":2,"time":"2018-04-16T01:33:07+00:00","remoteAddr":"66.119.108.54","user":"--","app":"core","method":"GET","url":"\/schwimscloud\/remote.php\/webdav\/","message":"Login failed: 'bob' (Remote IP: '66.119.108.54')"}

but if I try to log in with the proper credentials, nothing shows up in the log even though I still receive the same error.


#3

Maybe the Debian version of the client is too outdated for your server version?


#4

I'm not using the sync-client anymore, but I remember having a similar problem in the past.

Maybe this helps: Remove all the sync-clients hidden config stuff from your home directory. Then start over with a new setup.


#5

The OC download page has instructions for Jessie, so I'm guessing it's not too old since they include it in the instructions.


#6

I can't find any hidden directories, either in my user root or under .config. Is it located somewhere else or perhaps it didn't get a chance to be created since this app never allowed me a successful login?


#7

I think it might help if you post the current used version of the client. :slight_smile: Maybe something went wrong and you're using the outdated version of jessie?


#8

Hi there Tom and thanks for the help.

Debian is fully patched. Owncloud client versions shows Version 1.7.0-beta1+really1.6.4+dfsg-1+deb8u1

I see nothing in the Owncloud logs when I set it to "Everything". I tried logging in and it showed some cron jobs but absolutely nothing about an attempted login. It's as if the client is trying to log into another address instead of what I'm typing.


#9

Hey,

exactly this was the problem i had tried to point out:

1.6.4 is really too outdated. I know that because i had seen the following in the past:

Requires to use the latest desktop client version 2.3

https://doc.owncloud.org/server/latest/admin_manual/release_notes.html#id12


#10

Thanks for that Tom. I removed the version that ownCloud provides when you follow the install instructions and attempted to install the deb provided and got:

dependency is not satisfiable libowncloudsync0

When searching I've found others with the problem but no solutions. Does anyone know how to get this installed?


#11

I think installing the .deb directly isn't working as expected. You probably should follow the instructions on how to add the Debian 8.0/Jessie repositories here:

https://software.opensuse.org/download/package?project=isv:ownCloud:desktop&package=owncloud-client

and just do an "apt-get install owncloud-client" to get the latest version.