Many "operation canceled"/"connection closed" errors during sync


I have ownCloud 9.1.4 running on a Manjaro Linux server with php 7.0 and it seems to work fine with my desktop client also running Manjaro Linux with the ownCloud desktop sync client 2.2.4.

It has worked well for a long time, but over the past week the sync client has been producing a lot of "operation canceled" or "connection closed" errors for files during sync. I can confirm that those files have not been successfully uploaded to my ownCloud server. What is wrong and how do I troubleshoot this? Thank you!

BTW, I checked the ownCloud log and it seems that the errors coincided with messages like this:

{"reqId":"2F7+p8bHc+6uk9ZTl1hG","remoteAddr":"","app":"webdav","message":"Exception: {\"Message\":\"HTTP\\/1.1 400 expected filesize 347294 got 8192\",\"Exception\":\"Sabre\\DAV\\Exception\\BadRequest\",\"Code\":0,\"Trace\":\"#0 \\/srv\\/http\\/owncloud\\/apps\\/dav\\/lib\\/Connector\\/Sabre\\/Directory.php(136): OCA\\DAV\\Connector\\Sabre\\File->put(Resource id #433)\n#1 \\/srv\\/http\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV\\/Server.php(1036): OCA\\DAV\\Connector\\Sabre\\Directory->createFile('Pen Oxford buse...', Resource id #433)\n#2 \\/srv\\/http\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV\\/CorePlugin.php(523): Sabre\\DAV\\Server->createFile('documents\\/Durha...', Resource id #433, NULL)\n#3 [internal function]: Sabre\\DAV\\CorePlugin->httpPut(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#4 \\/srv\\/http\\/owncloud\\/3rdparty\\/sabre\\/event\\/lib\\/EventEmitterTrait.php(105): call_user_func_array(Array, Array)\n#5 \\/srv\\/http\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV\\/Server.php(459): Sabre\\Event\\EventEmitter->emit('method:PUT', Array)\n#6 \\/srv\\/http\\/owncloud\\/3rdparty\\/sabre\\/dav\\/lib\\/DAV\\/Server.php(248): Sabre\\DAV\\Server->invokeMethod(Object(Sabre\\HTTP\\Request), Object(Sabre\\HTTP\\Response))\n#7 \\/srv\\/http\\/owncloud\\/apps\\/dav\\/appinfo\\/v1\\/webdav.php(57): Sabre\\DAV\\Server->exec()\n#8 \\/srv\\/http\\/owncloud\\/remote.php(164): require_once('\\/srv\\/http\\/owncl...')\n#9 {main}\",\"File\":\"\\/srv\\/http\\/owncloud\\/apps\\/dav\\/lib\\/Connector\\/Sabre\\/File.php\",\"Line\":149,\"User\":\"[username]\"}","level":4,"time":"2017-02-24T13:13:47+00:00","method":"PUT","url":"\/owncloud\/remote.php\/webdav\/documents\/Durham\/2016-02\/Into%20the%20Night\/expenses%20forms\/hostel%20bus%20and%20living%20expenses%202017-02-21\/Pen%20Oxford%20buses%20Expense%20Form%202017-02-21.xlsx","user":"[myusername]"}

Just had a short search after this error with the search function on the top right and stumbled over this:

1 Like

Thanks @kljhlkhglklfgh for your quick response.

I haven't changed any of my PHP or Apache configurations in a long time. I'm running Manjaro Linux which is basically Arch Linux. Sorry I'm not familiar with this but specifically what logs should I look for other than what I have already posted? Thanks!

To me it looks most likely like a server configuration issue.

1 Like

The issue seems to have temporarily disappeared after a server restart. I hope it won't crop up again, but thanks for the responses so far. I'll report back if there are further problems.

I have the same issue, but i dont get it "server configuration issue"

I had the same problem and solved it by using another MPM.
I changed it from mod_mpm_event to mod_mpm_worker by editing the file /etc/httpd/conf.modules.d/00-mpm.conf.
There I had to uncomment the following line:
LoadModule mpm_worker_module modules/
and comment out this line:
#LoadModule mpm_event_module modules/

I'm on Fedora Server 26 so it could be that the config file is placed in another location like /etc/apache/something/mpm.conf

Hope this helps.


@minils : thanks for posting this, seems to be the only solution out there.

just FYI: on Ubuntu16 you would change this like so:

sudo a2dismod mpm_event
sudo a2enmod mpm_worker
sudo service apache2 restart

Though is has not helped my … still looking …

1 Like