My android app can't connect after update to 10.0.2


#1

Actual behaviour

  • my android app can't connect owncloud server after upgrade to 10.0.2 from 9.1.1
    the app show unknow err occur
    when i test connection it show success,but when i click connect button it show unknow err occur

Expected behaviour

  • before upgrade ,my android app is ok

Steps to reproduce

Can this problem be reproduced with the official owncloud server?
(url: https://demo.owncloud.org, user: test, password: test)

Environment data

Android version:6.1

Device model: mi note 2

Stock or customized system:

ownCloud app version:2.1.2

ownCloud server version:10.0.2

Logs

Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

Insert your ownCloud log here

#2

Hi Joe1977,

I have the same problem!

Since upgrade, connections with web and desktop works perfectly, but with Android app it doesn't work.

Are you using LDAP or CAS backend for user?

Did you already find an fix?

Thanks


#3

sorry ,i am not using LDAP or CAS backend for user,
i still don't fix it , i hope owncloud community can resolve this problem.


#4

there are nobody get this problem in community??


#5

hello,i have resolved this problem,just need upgrade u android app version to 2.4.0
now ,it works.


#6

Thanks for your fast response.

I already have this app version and the problem isn't resolved!

However, I am pleased to know that your problem is resolved


#7

it's so sad, did u get some erro message? and what is hint?


#8

Hi @headstorm , if the app is still not working for you, please try downloading the ownCloud 2.5.0 beta from PlayStore or FDroid and copy here the logs that appear in the Logs section included in the side menu. They will be useful to fix the problem, thank you.


#9

Thank you for your reply.

I already have this app version, it doesn't work, when i try to connect, a warning appear and "see other" is write. But when i try to connect with another app like ocloud.de or cirrus, it work perfectly, i don't understand why!
The owncloud server log say nothing about this and i didn't find log section in app... could you explain to me how find log in app please?
Thank you for your help.


#10

To see the "Logs" option you have to open the side menu in your ownCloud 2.5.0 beta app. After that, you can copy those logs and paste them here, it will be useful to find the problem. Thanks.


#11

I'm sorry but i can't see no side menu in app because i can't To connect me in the app...


#12

I see, can you please download the last Android app version (2.5.0) which was released last Monday and give it a try? If it's still not working for you, could you please provide us some kind of test account of your server so that we can see what's happening? Thank you


#13

Hi,

Thank you for your Help! I already use app version 2.5.0 and nothing change... What types of access do you need? Where can i comminicate them securely?


#14

I've just written you privately @headstorm


#15

Hello !

After my android app upgrade to 2.9.2, it cannot see the folders anymore.

Ocloud.de works fine (version 2.8.2).

Could you help me?

Regards,

Ricardo Auada


#16

Hey @Ricardo_Auada,

from what i have read in the last few days the android app 2.9 requires a recent ownCloud version 10.0. Make sure that your server isn’t running an outdated version.

If you’re on a recent version then i think its probably the best to create a new thread instead of posing in an one year old one.