My files lock and then no matter how long, they NEVER unlock!

I have spent the past 3 days trying to get my files unlocked, and nothing is working. I tried to change the config.php file, using the information found in this forum, but none of them are working. the config.php file does not contain any of the information that you show in this forum, and your answers are 5 years old and do not apply to the current version.

I need to disable file locking all together, and the answers you have in this forum need to be updated to reflect the current version. here is what my config.php file looks like, and if anyone could let me exactly what to change in this file in order to disable permanently file-locking.

<?php $CONFIG = array ( 'instanceid' => 'oc3kydpwbxr4', 'passwordsalt' => '63015975343858282858214666965643', 'secret' => 'whswhovflvdlwadjnsu4xtytwaojy3luhamlo9lae8wewc7s2bhkyxmajme8ssive28mmp8s0dzkluid3h1douwxsg7vllkq', 'trusted_domains' => array ( 0 => 'REMOVED', ), 'datadirectory' => '/home/fnxyz/ownclouddata', 'overwrite.cli.url' => 'https://REMOVED', 'dbtype' => 'mysql', 'version' => '10.11.0.6', 'dbname' => 'fnxyz_ownc436', 'dbhost' => 'localhost', 'dbtableprefix' => 'oc_', 'mysql.utf8mb4' => true, 'dbuser' => 'fnxyz_ownc436', 'dbpassword' => 'Ap18(SE[N9', 'allow_user_to_change_mail_address' => '', 'logtimezone' => 'UTC', 'apps_paths' => array ( 0 => array ( 'path' => '/home/fnxyz/domains/REMOVED/public_html/apps', 'url' => '/apps', 'writable' => false, ), 'filelocking.enabled' => false, 'memcache.local' => '\OC\Memcache\APCu', 'memcache.locking' => '\OC\Memcache\Redis', 'redis' => [ 'host' => 'localhost', 'port' => 6379, ], 1 => array ( 'path' => '/home/fnxyz/domains/REMOVED/public_html/apps-external', 'url' => '/apps-external', 'writable' => true, ), ), 'installed' => true, );

I’m not certain, but I think your config is completely messed up. Tried to reformat it for better readability, but some items are mixed.

The locking/memcache/redis stuff in within the app-path section, where it maybe cannot be found.
And BTW, there are some more items that shouldn’t be published. :wink:

Pre:

<?php 
$CONFIG = array ( 
	'instanceid' => 'oc3kydpwbxr4', 
	'passwordsalt' => '63015975343858282858214666965643', 
	'secret' => 'whswhovflvdlwadjnsu4xtytwaojy3luhamlo9lae8wewc7s2bhkyxmajme8ssive28mmp8s0dzkluid3h1douwxsg7vllkq', 
	'trusted_domains' => array ( 
		0 => 'REMOVED', 
	), 
	'datadirectory' => '/home/fnxyz/ownclouddata', 
	'overwrite.cli.url' => 'https://REMOVED', 
	'dbtype' => 'mysql',
	'version' => '10.11.0.6', 
	'dbname' => 'fnxyz_ownc436', 
	'dbhost' => 'localhost', 'dbtableprefix' => 'oc_',
	'mysql.utf8mb4' => true, 
	'dbuser' => 'fnxyz_ownc436', 
	'dbpassword' => 'Ap18(SE[N9', 
	'allow_user_to_change_mail_address' => '', 
	'logtimezone' => 'UTC', 
	'apps_paths' => array ( 
		0 => array ( 
			'path' => '/home/fnxyz/domains/REMOVED/public_html/apps', 
			'url' => '/apps', 
			'writable' => false, 
		), 
		'filelocking.enabled' => false, 
		'memcache.local' => '\OC\Memcache\APCu', 
		'memcache.locking' => '\OC\Memcache\Redis', 
		'redis' => [ 
			'host' => 'localhost', 
			'port' => 6379, 
			], 
			1 => array (
				 'path' => '/home/fnxyz/domains/REMOVED/public_html/apps-external', 
				 'url' => '/apps-external', 
				 'writable' => true, 
			 ), 
		), 
	'installed' => true, 
 );

Post:

<?php 
$CONFIG = array ( 
	'instanceid' => 'oc3kydpwbxr4', 
	'passwordsalt' => '63015975343858282858214666965643', 
	'secret' => 'whswhovflvdlwadjnsu4xtytwaojy3luhamlo9lae8wewc7s2bhkyxmajme8ssive28mmp8s0dzkluid3h1douwxsg7vllkq', 
	'trusted_domains' => array ( 
		0 => 'REMOVED', 
	), 
	'datadirectory' => '/home/fnxyz/ownclouddata', 
	'overwrite.cli.url' => 'https://REMOVED', 
	'dbtype' => 'mysql',
	'version' => '10.11.0.6', 
	'dbname' => 'fnxyz_ownc436', 
	'dbhost' => 'localhost', 'dbtableprefix' => 'oc_',
	'mysql.utf8mb4' => true, 
	'dbuser' => 'fnxyz_ownc436', 
	'dbpassword' => 'Ap18(SE[N9', 
	'allow_user_to_change_mail_address' => '', 
	'logtimezone' => 'UTC', 
	'apps_paths' => array ( 
		0 => array ( 
			'path' => '/home/fnxyz/domains/REMOVED/public_html/apps', 
			'url' => '/apps', 
			'writable' => false, 
			), 
		1 => array (
			 'path' => '/home/fnxyz/domains/REMOVED/public_html/apps-external', 
			 'url' => '/apps-external', 
			 'writable' => true, 
		 ), 
	), 
	'filelocking.enabled' => false, 
	'memcache.local' => '\OC\Memcache\APCu', 
	'memcache.locking' => '\OC\Memcache\Redis', 
	'redis' => [ 
		'host' => 'localhost', 
		'port' => 6379, 
		], 
	'installed' => true, 
 );

Hope this helps. Good luck!