NEW installation (NOT an upgrade) stuck in "maintenance mode"

9.1.x
help

#1

Server configuration
Operating system: Ubuntu 16.04 (unity)
Web server: I have no idea what is being asked for here.....
Database: .... or here......
PHP version: ..... or here..... sorry
ownCloud version (see ownCloud admin page): 9.1.0
Updated from an older ownCloud or fresh install: Fresh

Integrity status for oC9+ ????? In my opinion, the status is awful

Login as admin user into your ownCloud and access
http://example.com/index.php/settings/integrity/failed
paste the results here.

I am unable to do this

This is my first ever attempt at doing anything with servers. So, this is all very new to me..... hence why I could not fill out most of the information requested in your template. I truly don't know what is being asked for. Well, I can tell you the problem I am having:

First time ever, fresh install of owncloud of any version on a computer running Ubuntu 16.04. The version of owncloud installed is 9.1.0. I followed the preferred linux installation instructions found at https://doc.owncloud.org/server/9.1/admin_manual/installation/linux_installation.html which says this:

The owncloud-deps packages install all dependencies: Apache, PHP, and MySQL.
owncloud-deps is not intended to be installed by itself, but rather is
pulled in by the metapackage owncloud.
Install the metapackage owncloud to get a complete installation with all dependencies.

So, I went to https://download.owncloud.org/download/repositories/stable/owncloud/ and installed both the repository and its key for Ubuntu_16.04 owncloud-9.1.0-1.1. Then, I installed the owncloud metapackage. That all went fine, no error or warning messages.

Then, I opened Firefox on that same computer, entered the URL of local host owncloud , and..... I was presented with a page that says this:

"This ownCloud instance is currently in maintenance mode, which may take a while.

This page will refresh itself when the ownCloud instance is available again.

Contact your system administrator if this message persists or appeared unexpectedly.

Thank you for your patience."

This is how it has been for a few hours now, I have a sinking feeling something is wrong.

Will someone please help me? I don't know what to do, nor how to investigate this. I found MANY posts about owncloud being stuck in maintenance mode, but they ALL had to do with attempted UPGRADES, not a fresh installation.

Of course, being stuck at this point, I'm not able to do things like login as administrator, check settings, etc.

Thanks in advance.


#2

Hi,

you can disable maintenance mode like described here:

https://doc.owncloud.org/server/9.1/admin_manual/maintenance/enable_maintenance.html


#3

Thank you.... but.....

when I disable maintenance mode, and then go to http://localhost/owncloud/ , then I get a different - and very confusing message:

_
Updating to 9.1.0

Exception: Updates between multiple major versions and downgrades are unsupported.

Detailed logs

Preparing update
Set log level to debug
Turned on maintenance mode
Exception: Updates between multiple major versions and downgrades are unsupported.

The update was unsuccessful. For more information check our forum post covering this issue.

Well, this is really crazy because..... I already have 9.1.0 installed. So, I still don't know what is wrong, nor what I should do.


#4

Hi,

it seems you had a previous ownCloud version installed which now gets upgraded to 9.1.0


#5

I just added a small hint in the FAQ how to find out the versions between you are stuck, so it should now be straight forward:


#6

I wish that were true.....

This is a fairly new computer I purchased directly from the vendor, owncloud did NOT come preinstalled.

This is the first time in my life I'm attempting to install owncloud.

So, No, I do not have a previous version of ownCloud installed.

If I do.... I don't know how it got there, nor do I know what I ought to do at this point.


#7

Thank you.

I just want to make sure I'm understanding the instructions correctly....

Even though this is a fresh installation, I should follow those instructions which refer only to an upgrade? (I'm not disputing you, I just want to make sure I'm doing the right thing, because on the surface it seems wrong to me, but what do I know.....)

The instruction says that I should start with 8.0.x. How do we know that is the version to start with?

step #2 says, "Update the owncloud package via the package manager" So, I should NOT try to go to localhost/owncloud to do the updating?


#8

Is it possible that you have tried to install OC 8.0 some time ago?

If you don't remember and you want to start with a fresh setup, just delete data/-folder (make sure there is nothing inside you want to keep!), and the config/config.php. Make sure that that database is empty. If you open ownCloud in your browser, you should get a setup-screen.


#9

Thank you for your help. Since I had no data entered yet that I cared about, I simply uninstalled owncloud via Synaptic, removed the owncloud folder at /var/www/owncloud , and then reinstalled. It is working now.