No Add button on files page

Please help us by providing the following info. Before posting please also check the pinned "Known issues" threads and make sure that you're running the latest available version for your oC release:

Steps to reproduce
1. Install owncloud latest version
2. log in

Expected behaviour
Tell us what should happen
Files page should appear with an "Add" button ("+" sign)
Actual behaviour
Tell us what happens instead
The files page opens, but there is no Add button
Server configuration
Operating system:
Web server: Apache (Web Hosting Hub shared server)
Database: MySQL or sqlite (tried both)
PHP version: 5.5
ownCloud version (see ownCloud admin page): 9.1.1 (also tried latest nextcloud with identical result.
Updated from an older ownCloud or fresh install: fresh install
Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

ownCloud log (data/owncloud.log)

Please paste possible errors in the following code block, see for more info

Integrity status for oC9+

Login as admin user into your ownCloud and access
paste the results here.

A missing Add (+) button mostly means that there are missing permissions within the data folder. Don't have time to search for it but at some documentation about the needed permissions are available.

What are the details to resolve this? I installed this with software, Softtaculous, provided by my hosting company, and it was a pretty automated install, no options for permissions. Please advise.


please get in touch with Softaculous or Webhoster support to get this solved.

A standard installation with the install methods from and by following the installation instructions from is not showing such issues.

So this is most likely something special with the Softaculous installation or the Webhoster where only people having the knowledge about those can help here. The "Add +" button will show up once the installation is correctly done and nothing is messing around from webserver / environment side.

Might be also possible that the Web Hosters environment (Webserver, PHP,...) is messing around with the Javascript of this Button or similar. Or you have some issues with your browser, or Cloudflare/other services messing around with Javascript are enabled.

Overall, the Webhosters support might be able to tell you by having a look at the webservers logfiles or by checking the installed modules.

Thanks. I uninstalled the Softtaculous version, and installed using the 'ownCloud Web Installer' method, and it says it was successful. However, when I login, there is still no Add button. Any other suggestions?

Here I see this message:
Security & setup warnings

Your web server is not yet set up properly to allow file synchronization because the WebDAV interface seems to be broken.
You are accessing this site via HTTP. We

strongly suggest you configure your server to require using HTTPS
instead as described in our security tips.


that might be also a reason. Shared hoster are known for such issues as they are quite often blocking various WebDAV stuff or similar.

Ok, should I reach out to them, and give them the error, and maybe the link, or any other suggestions. I'm not most familiar with web design.

See also this shiny new FAQ about that environmental issue: