No upload bigger than 700kb while using cellular data

Steps to reproduce

1.Switch mobile phone to only using cellular data
2.upload files bigger than ~700kb

Expected behaviour

Upload of files bigger than 700KB.

Actual behaviour

Nothing happens, no error occures and no log entrie is created.
Same behaviour if I use the smartphone as a hotspot and try to Upload from a laptop.
If a wireless network is used, no problems occure, I can upload for example 4GB of backups.

Server configuration

Operating system: Red Hat enterprise linux 7.9

Web server: httpd-2.4.6-97.el7_9.x86_64

Database: 5.5.68-MariaDB

PHP version: php-7.2.34-3.el7.remi.x86_64

ownCloud version: 10.6.0.5

Updated from an older ownCloud or fresh install: Updated

**Where did you install ownCloud from: ownCloud Repository

List of activated apps:
Enabled:

  • activity: 2.6.0
  • comments: 0.3.0
  • configreport: 0.2.0
  • dav: 0.6.0
  • diagnostics: 0.1.4
  • encryption: 1.4.0
  • federatedfilesharing: 0.5.0
  • federation: 0.1.0
  • files: 1.5.2
  • files_external: 0.7.1
  • files_mediaviewer: 1.0.4
  • files_pdfviewer: 0.12.1
  • files_sharing: 0.14.0
  • files_texteditor: 2.3.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • market: 0.6.0
  • mynewtheme: 1.0.0
  • notifications: 0.5.2
  • password_policy: 2.1.2
  • provisioning_api: 0.5.0
  • systemtags: 0.3.0
  • templateeditor: 0.4.0
  • twofactor_backup_codes: 0.1.0
  • updatenotification: 0.2.1

**Are you using external storage, if yes which one: no
Are you using encryption: yes

Are you using an external user-backend, if yes which one: no

Client configuration

Browser: Chrome/Edge

Operating system: Android, Windows

Logs

Web server error log

No error added

ownCloud log (data/owncloud.log)

No error added
1 Like

I assume you’re running into a php timeout. How much time does it take for uploading? You might have y look at your php settings.

1 Like

It only takes 3-10 seconds to upload a 1MB file.
I can see the progress bar, when its filled, it disappears.

I set the max_execution_time to 300 while testing, it made no difference.

The problem is solved.
The firewall had rejected the requests.

1 Like