OC 10 menue icons missing

Hi there,

I’m running Owncloud 10.3.2 on Ubuntu 18.0.3 LTS which was running fine.
Everything worked fine till I activated SSL recently… now I have the issue that menue icons are not shown anymore.


I think something in my apache or oc config is wrong just can’t figure out what it is…

Server configuration

Operating system: Ubuntu 18.04.3 LTS

**PHP version:7.3

**Webserver version: Apache/2.4.41

**ownCloud version: 10.3.2

**Updated from an older ownCloud or fresh install: fresh install

**Where did you install ownCloud from: latest tar package

I hope I provided all necessary infromation!

some additional information:

this it what firefox shows me

Firefox show this path if I Investigate the Icon:

if I hover over the link it says grafic not found.

How did you enable SSL? With a reverse proxy, or directly in apache?
Please provide your SSL configuration.

1 Like


I generated an ssl cert and enabled ssl within apache.
Which apache config do you need exactly (there are two /etc/apache2/sites-available/000-default.conf and /etc/apache2/apache2.conf) sorry for the questions but I’m pretty new to OC :frowning:

I found a similar issue to mine but couldn’t solve it… (old version that’s why i created this new topic)

Sorry should have been more precise in my request, but I didn’t really think about it too much before.

I think we need your ownCloud apache configuration and what ever else you changed in your apache configuration to make SSL work, in order to be able to help you here.

Have you already had a look into the different apache log files for some error messages?

1 Like


there is no owncloud apache config, I was already wondering about that. (but it worked without ssl enabled before!) I only edited the two files mentioned above.
here the only changes I made to /etc/apache2/sites-available/default-ssl.conf

<IfModule mod_ssl.c>

        <VirtualHost _default_:443>
                ServerAdmin webmaster@localhost
                DocumentRoot /var/www/html/owncloud

                SSLCertificateFile      /etc/apache2/ssl/owncloud.crt
                SSLCertificateKeyFile /etc/apache2/ssl/owncloud.key

and /etc/apache2/apache2.conf

<Directory />
        Options FollowSymLinks
        AllowOverride None
        Require all denied

<Directory /usr/share>
        AllowOverride None
        Require all granted

<Directory /var/www/>
        Options Indexes FollowSymLinks
        AllowOverride All
        Require all granted

Can’t attach files because I’m a new user :confused:
Hope you can work with that?

Do you only access your ownCloud via the IP address (
Is your ownCloud installed in /var/www/html/owncloud?

I guess you installed a Let’s Encrypt certificate for a specific domain? Then you would have to write that domain in to your ServerName.

1 Like

Yes thats the path owncloud is installed in.
I added the following fqdn when I created the ssl cert.
owncloud.hanseorga-ag.de is that maybe the issue?

I just followed this tutorial:

I just changed my Servername in default-ssl.conf to the fqdn but still no luck

hope it is ok to post that!

I just double checked my apache ssl configuration for a local self signed cert, and I don’t have a ServerName defined at all, perhaps you want to try taking it out completely.
The section you posted from your /etc/apache2/apache2.conf looks standard to me, what did you change there?

1 Like

Thanks for your reply, I removed the servername entry without any change. I also changed the DocumentRoot within the same file back to /var/www, received an error and changed it back to /var/www/html/owncloud now it works all of a sudden… :slight_smile:
very strange but thank you for your help this is solved now!



i think it should be noted that the move of the DocumentRoot for an already installed ownCloud could bring up various problems if the data directory location moved as well:

1 Like