Owncloud 10.0 behind Nginx reverse proxy


#1

Steps to reproduce

  1. Fresh install Owncloud 10.0.2 on Debian 9
  2. Setup Nginx as reverse proxy for Owncloud

Expected behaviour

Normal Owncloud behaviour

Actual behaviour

When I login as admin I get this warning

This directory is unavailable, please check the logs or contact the administrator

Error on the admin page

Your web server is not yet set up properly to allow file synchronization because the WebDAV interface seems to be broken.

Server configuration

Operating system: Debian 9

Web server: Apache 2.4.25

Database:Mariadb 10.1.23-9+deb9u1

PHP version:PHP 7.0.19-1

ownCloud version: (see ownCloud admin page) 10.0.2 (stable)

Updated from an older ownCloud or fresh install: fresh install

Where did you install ownCloud from: https://download.owncloud.org/community/owncloud-10.0.2.tar.bz2

The content of config/config.php:

{
"system": {
"instanceid": "ocveunqme074",
"passwordsalt": "REMOVED SENSITIVE VALUE",
"secret": "REMOVED SENSITIVE VALUE",
"trusted_domains": [
"domain.com",
"Public IP,
],
"datadirectory": "REMOVED SENSITIVE VALUE",
"overwrite.cli.url": "https:\/\/domain.com\/owncloud",
"dbtype": "mysql",
"version": "10.0.2.1",
"dbname": "cloud",
"dbhost": "127.0.0.1",
"dbtableprefix": "oc_",
"dbuser": "REMOVED SENSITIVE VALUE",
"dbpassword": "REMOVED SENSITIVE VALUE",
"logtimezone": "UTC",
"installed": true,
"forwarded_for_headers": [
"HTTP_X_FORWARDED_FOR"
],
"loglevel": "0",
"overwritehost": "domain.com",
"overwriteprotocol": "https",
"overwritewebroot": "\/owncloud"
}
}

List of activated apps:
Enabled:
- configreport: 0.1.1
- dav: 0.2.9
- federatedfilesharing: 0.3.0
- federation: 0.1.0
- files: 1.5.1
- files_external: 0.7.0
- files_sharing: 0.10.0
- files_trashbin: 0.9.0
- files_versions: 1.3.0
- files_videoplayer: 0.9.8
- gallery: 16.0.2
- notifications: 0.3.0
- templateeditor: 0.1
- updatenotification: 0.2.1
Disabled:
- comments
- encryption
- external
- files_antivirus
- firstrunwizard
- market
- provisioning_api
- systemtags
- theme-example
- user_external

Are you using external storage, if yes which one: no

Are you using encryption: no

**Are you using an external user-backend, if yes which one: no

Client configuration

Browser: Chromium

Operating system: Kali linux

Logs

ownCloud log (data/owncloud.log)

{"reqId":"ypOwIkvFjsfOYaZHxYCg","level":4,"time":"2017-08-03T21:23:00+00:00","remoteAddr":"xxx.xxx.xxx.xxx","user":"user","app":"webdav","method":"PROPFIND","url":"\/owncloud\/\/remote.php\/webdav\/","message":"Exception: {\"Message\":\"Requested uri (\\\/owncloud\\\/\\\/remote.php\\\/webdav\\\/) is out of base uri (\\\/owncloud\\\/\\\/remote.php\\\/webdav\\\/)\",\"Exception\":\"LogicException\",\"Code\":0,\"Trace\":\"#0 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(1295): Sabre\\\\HTTP\\\\Request->getPath()\\n#1 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(474): Sabre\\\\DAV\\\\Server->checkPreconditions(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#2 \\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/dav\\\/lib\\\/DAV\\\/Server.php(254): Sabre\\\\DAV\\\\Server->invokeMethod(Object(Sabre\\\\HTTP\\\\Request), Object(Sabre\\\\HTTP\\\\Response))\\n#3 \\\/var\\\/www\\\/owncloud\\\/apps\\\/dav\\\/appinfo\\\/v1\\\/webdav.php(63): Sabre\\\\DAV\\\\Server->exec()\\n#4 \\\/var\\\/www\\\/owncloud\\\/remote.php(165): require_once('\\\/var\\\/www\\\/ownclo...')\\n#5 {main}\",\"File\":\"\\\/var\\\/www\\\/owncloud\\\/lib\\\/composer\\\/sabre\\\/http\\\/lib\\\/Request.php\",\"Line\":214,\"User\":\"user\"}"}

Hello all,

I hope I can get help here.
My issue is very similar to this one:
https://forum.owncloud.org/viewtopic.php?t=35110 and I already try the 2 links from this topic but they didn't work for me.
Any other ideas ?
Maybe I just missed something in my Nginx conf ...

      location /owncloud {

    proxy_pass http://domain.com/owncloud;

    }

Thank's.