Owncloud availability outside my LAN


#1

I have been using ownCloud on my LAN only for some months now and decided to make it accesible outside my LAN. I create a hotsname with NOIP, created a self signed certificate, changed the config.php and connected to my server from outside. The thing is I can connect my Owncloud client without difficulties but when I try to connected to the same URL from a browser (from outside my network), it says it cannot establish a secure connection t my ownCloud. HTTPS Root access is possible though.

How is it possible to be able to access my ownCloud server from the OC client and not from a Browser??? When I connect to my OC with the server external IP address, it does works from a browser...

Any help????


#2

Hi,

So you type in the same URL in your browser and your Client, like https://myowncloud.com

And on your Client you can see and sync your files

But in your browser you can't?


#3

Exactly! In other words...

https://myNOIPhostname:port/owncloud works from the ownCloud client.
https://myNOIPhostname:port/owncloud does not work form a browser.
https://myNOIPhostname:port works from a browser.
https://myExternalIPaddress:port works from a browser.
https://myExternalIPaddress:port/owncloud works from a browser.


#4

can you provide the apache configuration for port 80 and 443?

do you have any log files?

can you press F12 in the browser and check which error appears in the console when:


#5

I am realizing the I am a newbie. I have no idea how to find the Apache configuration, or the logs. Will have to learn how Apache works...
:frowning:


#6

Hi,

you could just go to this directory and post all the files you have here:

/etc/apache2/sites-enabled


#7

That I can do! I hope I am not passing sensitive data...

000-default.conf -> ../sites-available/000-default.conf

    <VirtualHost *:80>
    # The ServerName directive sets the request scheme, hostname and port that
    # the server uses to identify itself. This is used when creating
    # redirection URLs. In the context of virtual hosts, the ServerName
    # specifies what hostname must appear in the request's Host: header to
    # match this virtual host. For the default virtual host (this file) this
    # value is not decisive as it is used as a last resort host regardless.
    # However, you must set it for any further virtual host explicitly.
    #ServerName www.example.com

    ServerAdmin webmaster@localhost
    DocumentRoot /var/www/html

            Redirect "/" "https://lafourmi.ddns.net/"
    # Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
    # error, crit, alert, emerg.
    # It is also possible to configure the loglevel for particular
    # modules, e.g.
    #LogLevel info ssl:warn

    ErrorLog ${APACHE_LOG_DIR}/error.log
    CustomLog ${APACHE_LOG_DIR}/access.log combined

    # For most configuration files from conf-available/, which are
    # enabled or disabled at a global level, it is possible to
    # include a line for only one particular virtual host. For example the
    # following line enables the CGI configuration for this host only
    # after it has been globally disabled with "a2disconf".
    #Include conf-available/serve-cgi-bin.conf
   </VirtualHost>

default-ssl.conf -> ../sites-available/default-ssl.conf

.
<VirtualHost default:443>
ServerAdmin myemail
ServerName lafourmi.ddns.net

	DocumentRoot /var/www/html

	# Available loglevels: trace8, ..., trace1, debug, info, notice, warn,
	# error, crit, alert, emerg.
	# It is also possible to configure the loglevel for particular
	# modules, e.g.
	#LogLevel info ssl:warn

	ErrorLog ${APACHE_LOG_DIR}/error.log
	CustomLog ${APACHE_LOG_DIR}/access.log combined

	# For most configuration files from conf-available/, which are
	# enabled or disabled at a global level, it is possible to
	# include a line for only one particular virtual host. For example the
	# following line enables the CGI configuration for this host only
	# after it has been globally disabled with "a2disconf".
	#Include conf-available/serve-cgi-bin.conf

	#   SSL Engine Switch:
	#   Enable/Disable SSL for this virtual host.
	SSLEngine on

	#   A self-signed (snakeoil) certificate can be created by installing
	#   the ssl-cert package. See
	#   /usr/share/doc/apache2/README.Debian.gz for more info.
	#   If both key and certificate are stored in the same file, only the
	#   SSLCertificateFile directive is needed.
	SSLCertificateFile	/etc/ssl/certs/apache-selfsigned.crt
	SSLCertificateKeyFile /etc/ssl/private/apache-selfsigned.key

	#   Server Certificate Chain:
	#   Point SSLCertificateChainFile at a file containing the
	#   concatenation of PEM encoded CA certificates which form the
	#   certificate chain for the server certificate. Alternatively
	#   the referenced file can be the same as SSLCertificateFile
	#   when the CA certificates are directly appended to the server
	#   certificate for convinience.
	#SSLCertificateChainFile /etc/apache2/ssl.crt/server-ca.crt

	#   Certificate Authority (CA):
	#   Set the CA certificate verification path where to find CA
	#   certificates for client authentication or alternatively one
	#   huge file containing all of them (file must be PEM encoded)
	#   Note: Inside SSLCACertificatePath you need hash symlinks
	#		 to point to the certificate files. Use the provided
	#		 Makefile to update the hash symlinks after changes.
	#SSLCACertificatePath /etc/ssl/certs/
	#SSLCACertificateFile /etc/apache2/ssl.crt/ca-bundle.crt

	#   Certificate Revocation Lists (CRL):
	#   Set the CA revocation path where to find CA CRLs for client
	#   authentication or alternatively one huge file containing all
	#   of them (file must be PEM encoded)
	#   Note: Inside SSLCARevocationPath you need hash symlinks
	#		 to point to the certificate files. Use the provided
	#		 Makefile to update the hash symlinks after changes.
	#SSLCARevocationPath /etc/apache2/ssl.crl/
	#SSLCARevocationFile /etc/apache2/ssl.crl/ca-bundle.crl

	#   Client Authentication (Type):
	#   Client certificate verification type and depth.  Types are
	#   none, optional, require and optional_no_ca.  Depth is a
	#   number which specifies how deeply to verify the certificate
	#   issuer chain before deciding the certificate is not valid.
	#SSLVerifyClient require
	#SSLVerifyDepth  10

	#   SSL Engine Options:
	#   Set various options for the SSL engine.
	#   o FakeBasicAuth:
	#	 Translate the client X.509 into a Basic Authorisation.  This means that
	#	 the standard Auth/DBMAuth methods can be used for access control.  The
	#	 user name is the `one line' version of the client's X.509 certificate.
	#	 Note that no password is obtained from the user. Every entry in the user
	#	 file needs this password: `xxj31ZMTZzkVA'.
	#   o ExportCertData:
	#	 This exports two additional environment variables: SSL_CLIENT_CERT and
	#	 SSL_SERVER_CERT. These contain the PEM-encoded certificates of the
	#	 server (always existing) and the client (only existing when client
	#	 authentication is used). This can be used to import the certificates
	#	 into CGI scripts.
	#   o StdEnvVars:
	#	 This exports the standard SSL/TLS related `SSL_*' environment variables.
	#	 Per default this exportation is switched off for performance reasons,
	#	 because the extraction step is an expensive operation and is usually
	#	 useless for serving static content. So one usually enables the
	#	 exportation for CGI and SSI requests only.
	#   o OptRenegotiate:
	#	 This enables optimized SSL connection renegotiation handling when SSL
	#	 directives are used in per-directory context.
	#SSLOptions +FakeBasicAuth +ExportCertData +StrictRequire
	<FilesMatch "\.(cgi|shtml|phtml|php)$">
			SSLOptions +StdEnvVars
	</FilesMatch>
	<Directory /usr/lib/cgi-bin>
			SSLOptions +StdEnvVars
	</Directory>

	#   SSL Protocol Adjustments:
	#   The safe and default but still SSL/TLS standard compliant shutdown
	#   approach is that mod_ssl sends the close notify alert but doesn't wait for
	#   the close notify alert from client. When you need a different shutdown
	#   approach you can use one of the following variables:
	#   o ssl-unclean-shutdown:
	#	 This forces an unclean shutdown when the connection is closed, i.e. no
	#	 SSL close notify alert is send or allowed to received.  This violates
	#	 the SSL/TLS standard but is needed for some brain-dead browsers. Use
	#	 this when you receive I/O errors because of the standard approach where
	#	 mod_ssl sends the close notify alert.
	#   o ssl-accurate-shutdown:
	#	 This forces an accurate shutdown when the connection is closed, i.e. a
	#	 SSL close notify alert is send and mod_ssl waits for the close notify
	#	 alert of the client. This is 100% SSL/TLS standard compliant, but in
	#	 practice often causes hanging connections with brain-dead browsers. Use
	#	 this only for browsers where you know that their SSL implementation
	#	 works correctly.
	#   Notice: Most problems of broken clients are also related to the HTTP
	#   keep-alive facility, so you usually additionally want to disable
	#   keep-alive for those clients, too. Use variable "nokeepalive" for this.
	#   Similarly, one has to force some clients to use HTTP/1.0 to workaround
	#   their broken HTTP/1.1 implementation. Use variables "downgrade-1.0" and
	#   "force-response-1.0" for this.
	 BrowserMatch "MSIE [2-6]" \
			nokeepalive ssl-unclean-shutdown \
			downgrade-1.0 force-response-1.0

</VirtualHost>


#8

Okay, and what is the directory of your owncloud server?

is it /var/www/owncloud

or

/var/www/html/owncloud

also have you tried different browsers?


#9

It is in /var/www/owncloud.

I have made more tests, and now I realize that it does not work from within my LAN, but from outside, it does. And it is the same for my OC client. Now that I have connected to the NOIP hostname, once I connected to my own wifi, it loose connexion.

Sorry for this. The problem is completely different... :frowning:


#10

hm, and you connect to the noip hostname and get to your owncloud, or do you have to enter a /owncloud behind the noip hostname?

Because I have noticed your webroot is in /var/www/html


#11

I do enter https://hostname/owncloud to get to my owncloud...

Doesn't have something to do with Loopback policies???

Thanks for spending the time helping here!!!


#12

That's what I though.

If you change the DocumentRoot /var/www/html

to DocumentRoot /var/www/owncloud

you can enter just the hostname and you get to your owncloud without the /owncloud part

Try this in the ../sites-available/default-ssl.conf file


#13

Well, now it works without having to write /owncloud and the end of the URL but the problem stays the same. I cannot access from within my LAN!!!

:frowning:


#14

Maybe its just a router issue within your LAN?


#15

@tom42 following your tip, I start looking into forum about my own ISP and indeed, it was the configuration of the router.

It now works! Thanks a lot for this!!!

:slight_smile:
Edwin


#16

@tom42 saves the day :slight_smile:

thanks mate