Owncloud "backup detected" on external CIFS share

help

#1

Testing OC currently. Syncing of documents seems to work great. I created an external share and set it up to sync but every minute or so it prompts that a backup was detected. There was no restore, and the files in question are old files. If I remove the sync target and re-add it does the same thing and always for the same files. The external storage is a windows 2008r2 share.

I tried using an older version of the client to see if that made a difference (it didn't).

I tried deleting and recreating the external storage location on the owncloud control panel, but that also didn't resolve the issue.

I've confirmed that time settings are correct and synced between owncloud server, client, and windows server.

This issue persists on multiple clients (tested on desktop and laptop).

Is there any way to find out WHY it believes these documents keep changing? Is there anything that can be done to resolve this?


#2

Its a classic "works for me". So in order to help anybody will need a proper description how to reproduce with all the version numbers, config reports and log files in question ...


#3

Client version 2.2.4.6408
Server Version 9.1.2

Do I just "download logfile" from the admin section and attach the entire file here? Where can I find the "config reports"?


#4

Hiya @degol as it surely has to do with what's happening under the hood of the Desktop Sync Client, what it's happening is going to be in those logs; here you have the docs: https://doc.owncloud.org/desktop/2.2/advancedusage.html explaining how to get to them.


#5

https://dl.dropboxusercontent.com/u/29608896/log.zip

Here is the log, i paused everything except the sync target that was causing the issue to try and keep the size down. I appreciate your help.


#6

I see in the log its complaining that the dates don't match, when I look at the Modified stamp on local and remote, they are off by 1 second. Any thoughts on why that is happening? But its only happening on 23 of the files out of the 1,000 or so in the current sync target? And it never fixes itself, its consistently the same 23 files are off by 1 second every time they are copied down.


#7

Also if i manually copy over one of the trouble files, the local does now match the timestamp of the remote. But only if i copy through explorer, not if I allow owncloud to sync it.


#8

Just checking in, anyone have thoughts on this?


#9

This issue is improved (or even fixed) with 2.3
Would you want to try a nightly build and report back here?
https://owncloud.org/install/#testing-development


#10

Great thank you! I will give that a try and report back.


#11

@guruz any link what happened here and is fixed in 2.3? Thx.


#12

#13

should i be installing the testing build server, client, or both?


#14

I updated the client to the newest nightly, but the same thing is happening. When it syncs certain files (always the same ones), it syncs them as being 1 second newer than the file on the server (not all files in the folder, just some). Then it continuously resyncs it and replaces it (the newer nightly at least doesn't prompt and hold up all of the other syncs from running).