Owncloud can not connect to onlyoffice

Hello
we found error when try to connect owncloud to onlyoffice detail as below
Error when trying to connect (Client error response [url] https://mydomain/cache/files/conv_check_1068093185_docx/output.docx/output.docx?md5=cXGK8qp26wha0yjibXU4xQ%3D%3D&expires=1589684725&disposition=attachment&ooname=output.docx [status code] 403 [reason phrase] Forbidden)

  • Can you connect from your ownCloud cli to the ONLYOFFICE document server via curl?
  • Can you connect from your ONLYOFFICE cli to the ownCloud via curl?
  • Can your local machine connect to ONLYOFFICE and ownCloud via curl?
curl -I https://owncloud.tld
curl -I https://onlyoffice.tld

Both of these should reply with a 302 and Location in the reply headers. If you’re unsure you can also just paste them here.

1 Like

Hello I have the same problem after upgrading owncloud to 10.4.1 Can’t connect to onlyoffice document server. I’ve tested connections:
using curl -I http://myonlyofficeip from owncloud server got 302 and location response.
using curl -i http://myowncloudserver.tld from onlyoffice document server and got 301 and location response
and from my local machine I can connect to both servers via curl
Any help? any clue?
Thanks

What is the location response? I guess there is some redirect to HTTPS?

Make sure you have proper certificates installed as self-signed won’t work.

1 Like

Hi, I don’t know if you are running onlyoffice with docker or with a package system, but I have this tutorial that covers the whole installation and configuration process, including the part of the token that it is your problem maybe, like was mine.

Check it out, it is written in spanish language, but I think that you will find it useful. Tell as what you find.

Maybe the debconf settings fits to similar settings in the docker config file.