Owncloud can't access outside the lan (solved)

Hello everyone !
I have set up owncloud on ubuntu 18.04 Lts. followed avoiderror’s tutorial link https://www.youtube.com/watch?v=quBNkcx_a58

I get in on the lan but not on wan, I have searched and tried out. Added wan ip on trusted domain but dosen’t work…

Did port forward on router too

Help?? :open_mouth:


i think “doesn’t work” is lacking quite a lot information. Maybe you could explain this in a little bit more detail?

thank you for answer

I needed to restart the router after port forward then it work with the ip adress. but when I try to access from domain 'http://xxxxx.ddns.net/owncloud', it says " You access the server from an untrusted domain.
Please contact your administrator. If you are an administrator of this instance, configure the "trusted_domains" setting in config / config.php. An example configuration is provided in config / config.sample.php or at the documentation." 

I already added domain name in config file .


$CONFIG = array (
  'instanceid' => 'xxxxxxxxxxx',
  'passwordsalt' => 'xxxxxxxxxxxxxxxxxxxxx/',
  'secret' => 'xxxxxxxxxxxxxxxxxxxxxxxxxxxxx',
  'trusted_domains' => 
  array (
    0 => '',
    1 => 'xxx.xxx.xxx.xxx',
    2 => 'xxxxx.ddns.net/owncloud',
  'datadirectory' => '/var/www/html/owncloud/data',
  'overwrite.cli.url' => 'http://xxxxx.ddns.net/owncloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'owncloud',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'xxxxx',

The folder /owncloud is NOT a part of the domain. I think, you should remove it.

2 => ‘xxxxx.ddns.net’,

1 Like

Thanks for the reply alfredb
Now it works! :smile:

got question nr 2 I’m having trouble with HTTPS bit
I followed and done exactly like this link https://www.avoiderrors.com/enable-ssl-owncloud-ubuntu/ but something is wrong dont know where.

Glad to hear it works.

Please move the 2nd question regarding https into a new thread and mark this one as solved.

1 Like