Owncloud client in ubuntu 16.0.4 server cli mode


#1

Hi Experts,
We have successfully installed own cloud server and using client in all windows machines.
Now I wanted to use desktop client in Ubuntu 16.04 / Cent OS Virtual machines.
Browsed the docs, unfortunately, am unable to find the correct one.
Help me out
Vijay DSK


#2

Hi,


#3

Hi ilja,
Thanks for your support.
Followed the document and able to install and connect to the server.
Unfortunately, am neither able to download any thing from the server nor upload to the server.
Help me what am missing?


#4

You gave us close to no info what your problem might be. Impossible to help that way.


#5

Sorry for the delayed reply.
I followed the doc https://doc.owncloud.com/desktop/1.8/ownCloudClientManual.pdf
and when i run the command
owncloudcmd / https://carla:secret@server/owncloud/remote.php/webdav/
am getting the following result…


11-09 12:59:28:347 [ info sync.accessmanager ]: 2 “” has X-Request-ID “e75cec81-8285-4cba-b40b-95d33888b1d2”
11-09 12:59:28:348 [ info sync.networkjob ]: OCC::JsonApiJob created for + “ocs/v1.php/cloud/capabilities” “”
11-09 12:59:28:727 [ warning sync.networkjob ]: QNetworkReply::NetworkError(ContentNotFoundError) “Server replied “404 Not Found” to “GET owncloud/ocs/v1.php/cloud/capabilities?format=json”” QVariant(int, 404)
11-09 12:59:28:727 [ info sync.networkjob.jsonapi ]: JsonApiJob of QUrl("/owncloud/ocs/v1.php/cloud/capabilities?format=json") FINISHED WITH STATUS “ContentNotFoundError Server replied “404 Not Found” to “GET owncloud/ocs/v1.php/cloud/capabilities?format=json””
11-09 12:59:28:728 [ warning sync.networkjob.jsonapi ]: Network error: “ocs/v1.php/cloud/capabilities” “Server replied “404 Not Found” to “GET /owncloud/ocs/v1.php/cloud/capabilities?format=json”” QVariant(int, 404)
11-09 12:59:28:728 [ debug default ] [ main(int, char**)::<lambda ]: Server capabilities QJsonObject()
Error connecting to server


I removed my server details in the above text.
But there are files in the server…
I could able to connect through browser and also with windows client.

Am removing the url’s as it is not accepting more than 2 urls
Please help.


#6

The client can’t find an ownCloud server at the given url. Check if you can access this url http://yourserver.com/owncloud/ocs/v1.php/cloud/capabilities


#7

Hi,
When tried the url in windows browser it is saying the following error…
The requested URL /owncloud/ocs/v1.php/cloud/capabilities was not found on this server.


#8

Hey,

when doing the same on the demo installation of ownCloud available below i’m getting a response (after the login). To me it seems there is a mis-configuration in your web server causing this behavior. Maybe you could verify your web server configuration according to the ownCloud documentation to get this to work?

https://demo.owncloud.org/ocs/v1.php/cloud/capabilities


#9

Thanks for the reply.
My installation is a part of Nethserver. It is not an individual installation.
I am using mail server and owncloud on the same box.


#10

Hey,

i don’t think that this has much relevance. If there is a problem in your web server configuration then i think it doesn’t matter much on which operating system ownCloud is installed.

I’m still suggesting to search for possible issues in your web server configuration by comparing it with the recommended configuration in the ownCloud documentation.


#11

Then, please let me know where to check?


#12

Hey,

the ownCloud documentation i had mentioned twice is located at https://doc.owncloud.org/. Maybe one of those documentations will help you:

https://doc.owncloud.org/server/latest/admin_manual/installation/source_installation.html#configure-apache-web-server

https://doc.owncloud.org/server/latest/admin_manual/installation/nginx_configuration.html

It could be also possible that you need to look into the documentation of your web server (which you havn’t mentioned yet).