OwnCloud error when working with accented file/folder names

10

#1

Hi guys, I have recently installed OwnCloud X in my Qnap NAS and everything is working fine except when I try to upload a file with accented word in it's name, the same is for folder. When I try to upload a file the upload fail both from web and from the MacOS app or if it succeed the file can't be managed (move, delete, rename). When creating a folder with accented name it succeed to create, but then it's impossible to rename, delete, move it.
More details will be reported below.

Thank you in advance for any help!

Steps to reproduce

  1. Upload file with accented file names / Create folder with accented names

Expected behavior

The file upload is successful and file/folder can be managed (move, delete, rename)

Actual behavior

File upload fail (HTTP 2.0 500 error) or if upload is successful the file/folder can't be managed

Server configuration

Operating system: Linux Embedded QNAP

Web server: Apache by QNAP

Database: MariaDB

PHP version:

ownCloud version: 10.0.2.1

Updated from an older ownCloud or fresh install: Fresh Install

Where did you install ownCloud from: Web Installer

Signing status (ownCloud 9.0 and above):

No errors have been found.

The content of config/config.php:

{
    "basic": {
        "license key": "***REMOVED SENSITIVE VALUE***",
        "date": "Mon, 14 Aug 2017 21:23:11 +0000",
        "ownCloud version": "10.0.2.1",
        "ownCloud version string": "10.0.2",
        "ownCloud edition": "Community",
        "server OS": "Linux",
        "server OS version": "Linux NAS01 4.2.8 #1 SMP Thu Jul 27 01:09:50 CST 2017 x86_64",
        "server SAPI": "fpm-fcgi",
        "webserver version": "Apache",
        "hostname": "***REMOVED SENSITIVE VALUE***",
        "user count": 4,
        "user directories": 4,
        "logged-in user": "Francesco Biondi"
    },
    "config": {
        "instanceid": "oc2z3355njcz",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [
            "***REMOVED SENSITIVE VALUE***",
            "***REMOVED SENSITIVE VALUE***"
        ],
        "datadirectory": "***REMOVED SENSITIVE VALUE***\/OwnCloud_Data",
        "overwrite.cli.url": "***REMOVED SENSITIVE VALUE***",
        "dbtype": "mysql",
        "version": "10.0.2.1",
        "dbname": "OwnCloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "logtimezone": "UTC",
        "installed": true,
        "mail_from_address": "ownCloud",
        "mail_smtpmode": "php",
        "mail_domain": "***REMOVED SENSITIVE VALUE***"
    },
    "integritychecker": {
        "passing": true,
        "enabled": true,
        "result": []
    },
    "core": {
        "": "cl",
        "backgroundjobs_mode": "ajax",
        "enable_external_storage": "no",
        "installedat": "1502554429.77",
        "lastcron": "1502745777",
        "lastupdateResult": "[]",
        "lastupdatedat": "1502744217",
        "public_files": "files_sharing\/public.php",
        "public_webdav": "dav\/appinfo\/v1\/publicwebdav.php",
        "shareapi_allow_links": "yes",
        "shareapi_allow_mail_notification": "yes",
        "shareapi_allow_public_notification": "yes",
        "shareapi_allow_public_upload": "yes",
        "shareapi_allow_resharing": "yes",
        "shareapi_allow_social_share": "no",
        "shareapi_default_expire_date": "no",
        "shareapi_enforce_links_password": "***REMOVED SENSITIVE VALUE***",
        "shareapi_exclude_groups": "yes",
        "shareapi_exclude_groups_list": "[\"Clienti\"]",
        "shareapi_only_share_with_group_members": "no",
        "umgmt_send_email": "true",
        "umgmt_show_backend": "false",
        "umgmt_show_email": "false",
        "umgmt_show_is_enabled": "false",
        "umgmt_show_last_login": "false",
        "umgmt_show_storage_location": "false"

Config file cutter here, too long to be posted as is. If more is needed just ask!

#2

Is your DB in UTF-8bin?


#3

I just checked: the database was created in UTF8_general_ci and if I check now the tables in it they results as Utf8_bin. Is it correct?

Thank you for your answer!


#4

DEFAULT_CHARACTER_SET_NAME utf8mb4
DEFAULT_COLLATION_NAME utf8mb4_general_ci