Owncloud files missing upon re-install

9.1.x
help

#1

I recently upgraded my Ubuntu machine to 16.04, I tried owncloud many years ago and never really got on with it. It's clear there's been a lot of development since then so thought I'd try it.
After upgrade my machine there's been an awful lot of hurdles to overcome and now I've reached a point I simply can't seem to find the answer for.

After upgrading Ubuntu and all relevant packages I completely purged mysql, phpmyadmin and owncloud from my system and reinstalled. There were some files leftover, and these were all removed prior to reinstalling. "A fresh start".

Eventually all running ok but upon re-installing the owncloud package the files to access the web interface simply haven't been installed.

Here's a look at the /var/www/ of my server:

drwxr-xr-x  5 root root 4096 Jan 21 23:07 .
drwxr-xr-x 14 root root 4096 Jan 21 15:20 ..
drwxr-xr-x  2 root root 4096 Jan 21 15:25 html
-rw-r--r--  1 root root   25 Jan 21 21:53 index.html
drwxr-xr-x  2 root root 4096 Feb 17  2014 logs
drwxr-xr-x 10 root root 4096 Oct 16  2014 phpvirtualbox

And inside the html folder just to be safe and see if it ended up there:

drwxr-xr-x 2 root root  4096 Jan 21 15:25 .
drwxr-xr-x 5 root root  4096 Jan 21 23:07 ..
-rw-r--r-- 1 root root 11510 Jan 21 15:25 index.html

Upon trying to reinstall the package I get this:

Reading package lists... Done
Building dependency tree
Reading state information... Done
owncloud is already the newest version (9.1.3-1.1).
0 to upgrade, 0 to newly install, 0 to remove and 0 not to upgrade.

I have all the prequisites installed and the MySQL database ready to go, Apache runs fine and I can access other services or web pages on the machine.

Not sure if just copying a default set of files will work, can anyone advise?


#2

Most likely that you have only uninstalled the owncloud package without uninstalling the owncloud-files package. The latter contains the files which are put into /var/www/owncloud


#3

Good tip, the owncloud-files package comes with owncloud so the server showed this was installed as well.
However, removing owncloud with apt-get and reinstalling the whole package worked.