Owncloud Invalid license key

Steps to reproduce

  1. Install UCS v5
  2. Connect to Existing Active Directory MS

Expected behaviour

Use owncloud with free license

Actual behaviour

owncloud show a popup message that report : " Invalid license key!
Please contact your administrator or sales@owncloud.com for a new license key."

Server configuration

UCS v5

**ownCloud version: 10.7

**Updated from an older ownCloud or fresh install: free installation



If possible, I’d recommend you to update to 10.8. There is a button to remove the license in the “enterprise license key” section (your last screenshot), so it’s easier to use it.
If it isn’t possible, you’ll need to remove the license manually from the DB (table oc_appconfig, appid enterprise_key), and in the config.php file (if present). Remove the entries, not just set an empty value.

2 Likes

i have no keys ‘enterprise_key’ in the field appid :

MariaDB [owncloud]> use owncloud
Database changed
MariaDB [owncloud]> select * from oc_appconfig where appid = ‘enterprise_key’;
Empty set (0.000 sec)

also the config.php is empty:

Are you sure you’re looking at the right places? Because ownCloud is detecting a license and those two are the only places where the license could be.
Could you show the config.php file (with any private data replaced)?

I don’t think Univention appliance offers oC 10.8 yet.

When I copied this I got:
ERROR 1054 (42S22): Unknown column '‘enterprise_key’' in 'where clause'

Not sure how you created this post, but make sure to check for string:

MariaDB [owncloud]> select * from oc_appconfig where appid = "enterprise_key";

Welcome to the MariaDB monitor. Commands end with ; or \g.
Your MariaDB connection id is 13562
Server version: 10.3.31-MariaDB-0+deb10u1 Debian 10

Copyright (c) 2000, 2018, Oracle, MariaDB Corporation Ab and others.

Type ‘help;’ or ‘\h’ for help. Type ‘\c’ to clear the current input statement.

MariaDB [(none)]> use owncloud
Reading table information for completion of table and column names
You can turn off this feature to get a quicker startup with -A

Database changed
MariaDB [owncloud]> select * from oc_appconfig where appid = “enterprise_key”;
Empty set (0.000 sec)

this is the resul of query “select * from oc_appconfig”

appid configkey configvalue
activity enabled yes
activity installed_version 2.6.0
activity types filesystem
backgroundjob lastjob 18
comments enabled yes
comments installed_version 0.3.0
comments types logging,dav
configreport enabled yes
configreport installed_version 0.2.0
configreport types filesystem
core backgroundjobs_mode cron
core first_install_version 10.7.0.4
core installedat 1638259774.4256
core lastcron 1638434641
core lastupdateResult {“version”:“10.8.0”,“versionstring”:“ownCloud 10.8.0”,“url”:“https:\/\/download.owncloud.org\/community\/owncloud-10.8.0.zip”,“web”:"https:\/\/doc.owncloud.org\/server\/10.7\/admin_manual\/maint$
core lastupdatedat 1638432664
core public_files files_sharing/public.php
core public_webdav dav/appinfo/v1/publicwebdav.php
dav enabled yes
dav installed_version 0.6.0
dav types filesystem
federatedfilesharing enabled yes
federatedfilesharing installed_version 0.5.0
federatedfilesharing types filesystem
federation enabled yes
federation installed_version 0.1.0
federation types authentication
files cronjob_scan_files 500
files enabled yes
files installed_version 1.5.2
files types filesystem
files_external enabled yes
files_external installed_version 0.7.1
files_external types filesystem
files_mediaviewer enabled yes
files_mediaviewer installed_version 1.0.4
files_mediaviewer types
files_pdfviewer enabled yes
files_pdfviewer installed_version 0.11.2
files_pdfviewer types
files_sharing enabled yes
files_sharing installed_version 0.14.0
files_sharing types filesystem
files_texteditor enabled yes
files_texteditor installed_version 2.3.0
files_texteditor types
files_trashbin enabled yes
files_trashbin installed_version 0.9.1
files_trashbin types filesystem
files_versions enabled yes
files_versions installed_version 1.3.0
files_versions types filesystem
firstrunwizard enabled yes
firstrunwizard installed_version 1.2.0
firstrunwizard types
market enabled yes
market files_mediaviewer 1.0.5
market files_pdfviewer 0.12.2
market files_texteditor 2.4.1
market installed_version 0.6.0
market market 0.6.1
market types
market user_ldap 0.15.4
notifications enabled yes
notifications installed_version 0.5.2
notifications types logging
provisioning_api enabled yes
provisioning_api installed_version 0.5.0
provisioning_api types prevent_group_restriction
systemtags enabled yes
systemtags installed_version 0.3.0
systemtags types logging
templateeditor enabled yes
templateeditor installed_version 0.4.0
templateeditor types
updatenotification core 10.8.0
updatenotification enabled yes
updatenotification installed_version 0.2.1
updatenotification types
user_ldap enabled yes
user_ldap installed_version 0.15.2
user_ldap s01has_memberof_filter_support 1
user_ldap s01home_folder_naming_rule
user_ldap s01last_jpegPhoto_lookup 0
user_ldap s01ldap_agent_password NTQwNmVhOGVmZDE5NjY2ZGFmYjJjNjg4YzU4NGE0NDU5N2FlYThjZWUyM2U1OWQ1MGIxOGFmOGU0ZjdiOGFiOQ==
user_ldap s01ldap_attributes_for_group_search
user_ldap s01ldap_attributes_for_user_search
user_ldap s01ldap_backup_host
user_ldap s01ldap_backup_port
user_ldap s01ldap_base dc=xxxxxx,dc=local
user_ldap s01ldap_base_groups dc=xxxxxx,dc=local
user_ldap s01ldap_base_users dc=xxxxxx,dc=local
user_ldap s01ldap_cache_ttl 600
user_ldap s01ldap_configuration_active 1
user_ldap s01ldap_display_name displayName
user_ldap s01ldap_dn cn=owncl-91057209,cn=memberserver,cn=computers,dc=xxxxxx,dc=local
user_ldap s01ldap_dynamic_group_member_url
user_ldap s01ldap_email_attr mailPrimaryAddress
user_ldap s01ldap_experienced_admin 0
user_ldap s01ldap_expert_username_attr uid
user_ldap s01ldap_expert_uuid_group_attr gidNumber
user_ldap s01ldap_expert_uuid_user_attr uid
user_ldap s01ldap_group_display_name cn
user_ldap s01ldap_group_filter (&(objectclass=posixGroup)(ownCloudEnabled=1))
user_ldap s01ldap_group_filter_mode 0
user_ldap s01ldap_group_member_assoc_attribute memberUid
user_ldap s01ldap_groupfilter_groups
user_ldap s01ldap_groupfilter_objectclass
user_ldap s01ldap_host ucs.xxxxxx.local
user_ldap s01ldap_login_filter (&(objectclass=person)(ownCloudEnabled=1)(|(uid=%uid)(mailPrimaryAddress=%uid)))
user_ldap s01ldap_login_filter_mode 0
user_ldap s01ldap_loginfilter_attributes
user_ldap s01ldap_loginfilter_email 0
user_ldap s01ldap_loginfilter_username 1
user_ldap s01ldap_nested_groups 0
user_ldap s01ldap_network_timeout 2
user_ldap s01ldap_override_main_server
user_ldap s01ldap_paging_size 500
user_ldap s01ldap_port 7389
user_ldap s01ldap_quota_attr ownCloudQuota
user_ldap s01ldap_quota_def
user_ldap s01ldap_tls 0
user_ldap s01ldap_turn_off_cert_check 0
user_ldap s01ldap_user_display_name_2
user_ldap s01ldap_user_filter_mode 0
user_ldap s01ldap_user_name samaccountname
user_ldap s01ldap_userfilter_groups
user_ldap s01ldap_userfilter_objectclass
user_ldap s01ldap_userlist_filter (&(objectclass=person)(ownCloudEnabled=1))
user_ldap s01use_memberof_to_detect_membership 0
user_ldap types authentication

Another new installation, this time with Univention Corporate Server 5.0-1 errata176, but alway the same problem …i don’t understand because there are no other peoples that have the same problem

the step is very simple :

  1. download from UCS Download as ISO or VMware Image – Univention the “VMware ESXi (1,2 GB)”

  2. Deploy the new VM from ESXi server … the config of VM it’s already done ( it’s OVA file ), must do only click on next button to start the VM

  3. Connect UCS to Microsoft active directory domain

  4. finish the installation and update the system, at the first logon i upload the license of UCS

  5. install owncloud from app center

  6. login to owncloud with the Microsoft administrator credential and the result is :

in the oc_appconfig there is not any appid = enterprise_key

I’m tired … i have made many installation with a different HW and ESXi servers and the result is alway the same, from today i’ll migrate to another system

1 Like

also the config.php is empty

Empty as in “file is missing” or “file without any content”, or it’s just the file has other content but there isn’t any reference to a license?

The config.php file musn’t be empty. It must have other information. If it’s empty it isn’t probably the right file.

I meant that the file does not have the enterprise_key string inside it:

<?php

$CONFIG = array (
‘apps_paths’ =>
array (
0 =>
array (
‘path’ => ‘/var/www/owncloud/apps’,
‘url’ => ‘/apps’,
‘writable’ => false,
),
1 =>
array (
‘path’ => ‘/var/www/owncloud/custom’,
‘url’ => ‘/custom’,
‘writable’ => true,
),
),
‘trusted_domains’ =>
array (
0 => ‘localhost’,
),
‘datadirectory’ => ‘/var/lib/univention-appcenter/apps/owncloud/data/files’,
‘dbtype’ => ‘mysql’,
‘dbhost’ => ‘172.17.42.1’,
‘dbname’ => ‘owncloud’,
‘dbuser’ => ‘owncloud’,
‘dbpassword’ => ‘bf5aa7b717acbbae3dc34a907bdd09563414bcfb1b0585fc837928791444a7af’,
‘dbtableprefix’ => ‘oc_’,
‘log_type’ => ‘owncloud’,
‘supportedDatabases’ =>
array (
0 => ‘sqlite’,
1 => ‘mysql’,
2 => ‘pgsql’,
),
‘upgrade.disable-web’ => true,
‘default_language’ => ‘en’,
‘overwrite.cli.url’ => ‘http://ucs.xxxx.local/owncloud’,
‘htaccess.RewriteBase’ => ‘/owncloud’,
‘logfile’ => ‘/var/lib/univention-appcenter/apps/owncloud/data/files/owncloud.log’,
‘loglevel’ => ‘3’,
‘memcache.local’ => ‘\OC\Memcache\APCu’,
‘mysql.utf8mb4’ => true,
‘filelocking.enabled’ => true,
‘memcache.distributed’ => ‘\OC\Memcache\Redis’,
‘memcache.locking’ => ‘\OC\Memcache\Redis’,
‘redis’ =>
array (
‘host’ => ‘redis’,
‘port’ => ‘6379’,
),
‘passwordsalt’ => ‘12345’,
‘secret’ => ‘12345’,
‘version’ => ‘10.7.0.4’,
‘logtimezone’ => ‘UTC’,
‘installed’ => true,
‘instanceid’ => ‘oc1w5sqb9p4m’,
‘ldapIgnoreNamingRules’ => false,
‘log_rotate_size’ => 104857600,
‘onlyoffice’ => array (‘verify_peer_off’ => TRUE),
);

  • What is inside the owncloud/config folder perhaps there are other example.config.php files.
  • You are using UCS which is based on docker, perhaps the environment has the license key set as variable? Find the owncloud docker folder on the UCS system and check all docker-(compose) and .env files. Perhaps UCS has some kind of interface were you can set environment variables.
    Alternatively you could also check whether this is set by running env in the ownCloud docker container (it needs to be properly initialised when starting the shell though)

According the the ownCloud docker base image the ENV variable is OWNCLOUD_LICENSE_KEY.
But I’m not sure if the appliance image is also based in this image.

I am facing same problem and can not find solution.

Funny thing: owncloud worked for me, but something happened and now it is displaying this “nag message”. I am personally blaming OwnCloud, but I am not 100% sure.

  1. I did not have multiple config.php files in /var/lib/univention-appcenter/apps/owncloud/conf/. Please do not suggest there is something wrong with auto-generated config. It worked well, until…
  2. OWNCLOUD_LICENSE_KEY is NOT set in running docker image. At least in my case. It is also not set in Univention registry (ucr dump | grep OWNCLOUD).
  3. There was no suggested entry in MySQL database (=> nothing to delete).

What else could be a problem? I hope it is not agressive OwnCloud marketing…

BTW (ucr dump | grep version/)
version/erratalevel: 177
version/patchlevel: 1
version/releasename: Blumenthal
version/version: 5.0

OwnCloud docker image:

version 10.7.0.4
versionstring 10.7.0
edition Community
productname ownCloud
hostname 7d5525349be0

Could it be the reason that Univention Owncloud appliance is shipped with “ownCloud X Enterprise Theme” which requires enterprise licensing? Can I somehow switch template to community one?

Perhaps I need to stop barking :slight_smile: DO NOT put (defaulted) “” (double quotation marks) in Univention App Centre details. Make sure you have blanks instead of double quotation marks.
Univention GUI seems to got broken? :frowning:

/var/lib/univention-appcenter/apps/owncloud/conf/config.php:
‘license-key’ => ‘""’,
‘marketplace.key’ => ‘""’,

Something is going crazy in /var/lib/univention-appcenter/apps/owncloud/data/files/owncloud.log too:
root@myhost:~# tail -n 1 /var/lib/univention-appcenter/apps/owncloud/data/files/owncloud.log
{“reqId”:“xfFZ64LhQMFtFWVSeyHl”,“level”:3,“time”:“2021-12-29T18:31:51+00:00”,“remoteAddr”:“172.17.42.1”,“user”:“owncloud”,“app”:“PHP”,“method”:“GET”,“url”:"/owncloud/license/licenseMessage?app=core",“message”:“in_array() expects parameter 2 to be array, null given at /var/www/owncloud/lib/private/License/BasicLicense.php#77”}