OwnCloud marketplace - Error

Hello,
we use the owncloud Server 10.4.1.
I tried to download an app from the marketplace, however I get an error:
No marketplace connection:cURL error 60:SSL certficate problem: unable to get local issuer certficate.

Does anybody knows what this error means and what I have to do?

Thanks for the help.

Hi,

Looks like you have problems with the SSL certificate the marketplace is using. Try to connect from the host where ownCloud is by using curl

1 Like

Hi,
thanks for the answer.
I tried this and I didn’t get any response - I had to quit the request; in the meantime I installed the app manually but of course it would be fine if the marketplace would work; by the way it has already worked.

  • Is your ownCloud behind a restrictive firewall or proxy which might interfere with the HTTPS connection?

As far as I can tell there is a working certificate installed on marketplace.owncloud.com at the moment.

However your error message is unable to get local issuer certficate and the certificate installed on the website is a Let’s Encrypt certificate which was only relatively recently (compared to other CAs) added to Linux distributions root CA trust store.

  • So perhaps you are running on a very old Linux install?

The post template for server issues asks for the distribution your system is installed on. Would you have cared to fill it out, I would already have that information :wink:

2 Likes

I was thinking the same… it looks like that you (@test723) are behind a Proxy

1 Like

Thanks for the help. Yes the server is behind a proxy; the problem was the https inspection. Now it works.

Do I understand it right that you had some Deep Packet inspection enabled in your proxy, which, once you disabled it, fixed your issue?
Or did you have to set the overwrite parameters in ownCloud to fix the issue?

Please clarify for future people running into this problem, thanks!

1 Like

No I did’nt have to set parameters. The problem was the SSL Inspection; this I had to disable (bypass) on the proxy.

1 Like