Persistant mainenance mode

Hey guys,

I have a little problem since i updated owncloud to version 10.2.1. My server is stuck in maintenance mode and i have no clue how to disable it.
Both, the console command sudo -u www-data php occ maintenance:mode --off and editing the config.php have no effect.
Using the console command the config.php is edited correctly but the maintenance mode is not disabled.

Probably the information below might help anyone.

installed	true
maintenance	true
needsDbUpgrade	true
version	""
versionstring	"10.2.1"
edition	"Community"
productname	"ownCloud"

Do you have any ideas what I could try?

Thanks for help!


did you try restarting PHP afterwards ? You might have some cache around.

1 Like

I tried even a full reboot of the server and nothing has helped.
Restarting apache and php had no effect.


erf too bad :confused:
Maybe there is a flag about that in the database but I didn’t find it yet.
I read you tried using occ and by editing the config.php file manually.
Could you retry both and restart PHP or Apache (if mod_php) afterwards ?
Did you clear your browser cache too ? Maybe try from another one.


I tried what you suggested… no effect.
The config.php is edited correctly by using occ and I also tried to enable maintenance mode manually via config.php and disable it afterwards.

The browser should not be the problem. Chrome, Firefox, Edge, Edge Dev (Chromium)… same problem everywhere. Deleting the cache was what I tried first. Do you have any other idea? I would not like to loose 90 GiB of encrypted data or at least have to try to restore the data.

I was not sure if I should post this here… stupid me. All the time (last 3 days) I edited an old copy of the occ installation and not the productive one.
So just changed the config.php, the updater worked fine and everything is fixed. Sorry for stressing your mind. :wink: Shutting my computer off now to not “break” anything else. :smiley:


ahah that’s brave of you to post this and it’s surely satisfying to know it’s fixed now !
A suggestion to not fell in this trap once again.

  • Edit your config.php and add for example
$CONFIG = array (
  'toto' => 'toto',
  • Run occ config:list
  • Search in the result if you have the string toto
# occ config:list
    "system": {
        "toto": "toto",

This way you ensure you are editing the correct config.php.
Would you mind setting your post as solved so no one will search on ?


thank you for the hint. The first thing I did was to delete the old backup and create a new one on a different machine. So this should never happen again. :wink:
I have changed some settings with apache in between and moved the whole web content to a subfolder of /var/www. The former oc installation was directly in /var/www… so the location seemed legit but was not.

I think the post should be set as solved. If not I would be thankful for info about how to do this correctly.

I am kind of happy since yesterday. :smiley:


i’m not sure if this is relevant but i have read in the past that you have to modify some database entries of ownCloud like described in if the location is changed.

But this only applies for existing installations, if the ownCloud installation on the new location was freshly installed on a fresh database then it shouldn’t be relevant.

Hey Tom,

thanks for the note but it was a fresh installation on the new location.

1 Like

Hey @FloK

If you don’t have any other websites on your machine then it’s fine to go with www-data else I would recommend to create a specific user with correct permissions.
I’m happy for you :slight_smile:
Cheers !

1 Like

Hey @cs35,
thank you but this is a machine only running for private purposes with no actual website on it.
It runs a Teamspeak Server, my owncloud and thats it. :wink:
So no need for multiple users.