Polls app disappeared

Hello everyone,

We’re using ownCloud 10.2.1 on Debian 9.11 and wanted to install Polls app but it’s no longer in Market.
Will it be back in a next version ?
Is there an other App doing the same job ?

Thanks for any information



it seems the polls app is still available at the marketplace:


From another app i had used on my own ownCloud i made the experience that it is sometimes required to manually update the appinfo/info.xml manually like described in ownCloud core switching to Semver, apps need re-release as long as the app author hasn’t updated its app for this required change.

Hello tom42,
Thanks again for your helping us ! We downloaded the app with your link, (but it’s still not reachable from the admin page). Then we installed it on our server, updated the info.xml as explained. App version was increased from 0.8.1 to 0.8.2 but we encounter an integrity code error. Trying a higher version number leads the server to hang and request occ upgrade. How did you deal with your app version number ?
Yours sincerely,


From my experience polls is only working up to 0.8.1 and only up to ownCloud 10.0.8
On the repository https://github.com/nextcloud/polls/ they write

Note : ownCloud is no longer supported! Last (confirmed) working version is 0.8.1 and is released in the oC marketplace.

So this app is abandoned for ownCloud until somebody takes the effort and creates a working fork.


i just have tested the polls app from https://marketplace.owncloud.com/apps/polls and can confirm that this is still working on my own ownCloud 10.3.0 installation after doing the following steps:

  1. Download the polls app from the marketplace
  2. Extracted the archive into my apps-external folder
  3. Changed <owncloud min-version="8.2" max-version="10.0" /> to <owncloud min-version="8.2" max-version="10" /> in the appinfo/info.xml
  4. Enabled the app in my admin backend of ownCloud (via http://mycloud/settings/admin?sectionid=apps&category=disabled)

@tom42 Yes, with those modifications I was able to enable the app, but it was unusable.

Did you actually create polls and did you try to to use them as other users? I was receiving a bunch of js errors and gave up patching. At least on 10.2.1 this was not working for me.

Hi all,

On our test server (oC 10.3.0) we followed the steps described by tom42 plus changed
0.8.1 to 0.8.2 in appinfo/info.xml.
The app works but badly works i.e.

  • polls cannot be neither modified nor deleted,
  • votes are not collected.
    It appears that cortho’s situation looks like ours.

We might look for something else or wait for someone to create a working fork.

Thanks for all contribs, best regards



oh no. I haven’t tested this because the app is marked as compatible with ownCloud 10.0 and in the announcement in https://owncloud.org/news/switching-owncloud-to-semantic-versioning-semver/ the ownCloud team stated the following:

The next minor version (which could be 10.2.0) will bring new features. All apps will continue working as before. API functionality is only expanded, not reduced.

It the app worked with e.g. 10.0 or 10.1 and stopped to work with 10.2 this looks contradictory to the statement of the ownCloud team. :confused:

I agree basically, only in the polls app semver is not considered, as they state max-version=“10.0” ( in semver this would be max-version=“10”)

So to me it reads it is not compatible with oc 10.1 and above, which matches my experience.

This is probably an issue at the marketplace, unfortunately I do not have the time to write a proper issue on github.

Maybe @dmitry would like to forward this internally.


i’m also not quite sure of this because https://owncloud.org/news/switching-owncloud-to-semantic-versioning-semver/ and ownCloud core switching to Semver, apps need re-release sounds to me that an app developer only needs to change the appinfo/info.xml and re-release the app with these changes to make it compatible with the newer ownCloud versions. :confused:

Ack, but only when the app remains exactly the same. This is not the fact with the polls app and the authors decided not to support ownCloud any longer in later releases.

To me it looks like latter versions of the app are depending on other versions of some js framework versions (I guess they were bumped on nextcloud but not on ownCloud). Obviously the developers didn’t take the effort to make it still compatible with ownCloud.

So it is rather an issue with the app itself and not with semver in general.