Problem with ldap users

ldap

#1

Hello! Enroll persistent errors in the. Can anyone met such.

Steps to reproduce

1.problems with LDAP after updating owncloud 9.1.6 to version 10.0.3

Expected behaviour

owncloud.log shows many errors of the type:
{"reqId":"nbqkIe3lhdaOEERxHSjw","level":3,"time":"2017-10-29T19:14:45+03:00","remoteAddr":"46.191.100.115","user":"--","app":"user_ldap","method":"POST","url":"\/index.php\/login","message":"Exception: {\"Exception\":\"Exception\",\"Message\":\"No user available for the given login name on 192.168.1.20:389\",\"Code\":0,\"Trace\":\"#0 \\/var\\/www\\/html\\/owncloud\\/apps\\/user_ldap\\/lib\\/User_LDAP.php(117): OCA\\User_LDAP\\User_LDAP->getLDAPUserByLoginName('ean')\n#1 [internal function]: OCA\\User_LDAP\\User_LDAP->checkPassword(*** sensitive parameters replaced )\n#2 \\/var\\/www\\/html\\/owncloud\\/apps\\/user_ldap\\/lib\\/User_Proxy.php(79): call_user_func_array(Array, Array)\n#3 \\/var\\/www\\/html\\/owncloud\\/apps\\/user_ldap\\/lib\\/Proxy.php(140): OCA\\User_LDAP\\User_Proxy->walkBackends('ean', 'checkPassword', Array)\n#4 \\/var\\/www\\/html\\/owncloud\\/apps\\/user_ldap\\/lib\\/User_Proxy.php(194): OCA\\User_LDAP\\Proxy->handleRequest('ean', 'checkPassword', Array)\n#5 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/User\\/Manager.php(215): OCA\\User_LDAP\\User_Proxy->checkPassword( sensitive parameters replaced )\n#6 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/User\\/Session.php(467): OC\\User\\Manager->checkPassword( sensitive parameters replaced )\n#7 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/User\\/Session.php(301): OC\\User\\Session->loginWithPassword( sensitive parameters replaced )\n#8 \\/var\\/www\\/html\\/owncloud\\/core\\/Controller\\/LoginController.php(201): OC\\User\\Session->login( sensitive parameters replaced )\n#9 [internal function]: OC\\Core\\Controller\\LoginController->tryLogin( sensitive parameters replaced ***)\n#10 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/AppFramework\\/Http\\/Dispatcher.php(159): call_user_func_array(Array, Array)\n#11 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/AppFramework\\/Http\\/Dispatcher.php(89): OC\\AppFramework\\Http\\Dispatcher->executeController(Object(OC\\Core\\Controller\\LoginController), 'tryLogin')\n#12 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/AppFramework\\/App.php(98): OC\\AppFramework\\Http\\Dispatcher->dispatch(Object(OC\\Core\\Controller\\LoginController), 'tryLogin')\n#13 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/AppFramework\\/Routing\\/RouteActionHandler.php(46): OC\\AppFramework\\App::main('LoginController', 'tryLogin', Object(OC\\AppFramework\\DependencyInjection\\DIContainer), Array)\n#14 [internal function]: OC\\AppFramework\\Routing\\RouteActionHandler->_invoke(Array)\n#15 \\/var\\/www\\/html\\/owncloud\\/lib\\/private\\/Route\\/Router.php(307): calluser_func(Object(OC\\AppFramework\\Routing\\RouteActionHandler), Array)\n#16 \\/var\\/www\\/html\\/owncloud\\/lib\\/base.php(928): OC\\Route\\Router->match('\\/login')\n#17 \\/var\\/www\\/html\\/owncloud\\/index.php(56): OC::handleRequest()\n#18 {main}\",\"File\":\"\\/var\\/www\\/html\\/owncloud\\/apps\\/user_ldap\\/lib\\/User_LDAP.php\",\"Line\":101}"}

Server configuration

Server configuration
"user_ldap" 0.9.1
Operating system: Ubuntu Server 15.10
Web server:Apache/2.4.12
Database:mariaDB 10.0.25
PHP version:PHP 5.6.11
ownCloud version (see ownCloud admin page): ownCloud 10.0.3 (stable)
Updated from an older ownCloud or fresh install:
Special configuration (external storage - nas, external authentication- ldap, reverse proxy - no, server-side-encryption-no):

Signing status (ownCloud 9.0 and above):

The content of config/config.php:

#### ownCloud log (data/owncloud.log)

Insert your ownCloud log here


#2

Hi,

What exactly is the problem?

Are the users not showing up, do you get an error on the web UI?

You can also write to me in Russian if you feel more comfortable.

Вы можите написать по русский.