Problematic installation on Raspberry Pi 4

Hello,
After a few days of struggling and tormenting properly installing owncloud, I gave up and decided to post in this forum asking for help.
At the moment, I’m using Raspberry Pi4B with installed Raspberry Pi OS. I’ve installed Docker (Docker version 20.10.8, build 3967b7d) and Portainer to easier manage containers.
I’ve tried many combinations of Portainer Stack (docker-compose), mostly main problem was with database which probably is not fully supported for RPi arm7v so I’ve tried “jsurf/rpi-mariadb” of db, mostly worked fine.

Sometime ago, I was already at the end of the correct installation. Everything worked fine, until enter to settings and read the safety warnings.

  • “Transactional file locking should be configured to use memory-based locking, not the default slow database-based locking.” was easly fixed by putting some code into config.php
  • Some error with cron job, easly fixed too.

But Redis made me give up. After configure it whole installation made it unusable. I couldn’t upload any file, small file upload try resulted in an unexpected error, a little biger files gave me “Redis server went away”. Nothing worked, in the logs - silence (no errors).

At the moment, I’ve completly dropped that installation cause I’ve didnt found any fix to that. I’ve tried many combinations of containers with images, I’m fed up right now, but I’d love to try again and make it work.
I have specially purchased a ssd to have my own, private cloud.

Could someone help me to create it and make everything works together and is error-free? Please…