Problems running occ command on console


#1

Hi,

we have setup an ownCloud environment with version 10.0.7. We tried to run commands using the occ tool, which runs perfectly fine in our other environments. We do recieve the following error and I don’t understand what went wrong:
www-data @ 3da81882081f: ~/owncloud # php occ

An unhandled exception has been thrown:

PDOException: SQLSTATE[42S02]: Base table or view not found: 1146 Table 'owncloud.appconfig' doesn't exist in /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php:104

Stack trace:

#0 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Driver/PDOConnection.php(104): PDO->query('SELECT * FROM `...')

#1 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Connection.php(852): Doctrine\DBAL\Driver\PDOConnection->query('SELECT * FROM `...')

#2 /var/www/owncloud/lib/private/DB/Connection.php(187): Doctrine\DBAL\Connection->executeQuery('SELECT * FROM `...', Array, Array, NULL)

#3 /var/www/owncloud/lib/composer/doctrine/dbal/lib/Doctrine/DBAL/Query/QueryBuilder.php(206): OC\DB\Connection->executeQuery('SELECT * FROM `...', Array, Array)

#4 /var/www/owncloud/lib/private/DB/QueryBuilder/QueryBuilder.php(141): Doctrine\DBAL\Query\QueryBuilder->execute()

#5 /var/www/owncloud/lib/private/AppConfig.php(301): OC\DB\QueryBuilder\QueryBuilder->execute()

#6 /var/www/owncloud/lib/private/AppConfig.php(80): OC\AppConfig->loadConfigValues()

#7 /var/www/owncloud/lib/private/AppConfig.php(278): OC\AppConfig->getApps()

#8 /var/www/owncloud/lib/private/legacy/app.php(1000): OC\AppConfig->getValues(false, 'installed_versi...')

#9 /var/www/owncloud/lib/private/Server.php(436): OC_App::getAppVersions()

#10 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC\{closure}(Object(OC\Server))

#11 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet('MemCacheFactory')

#12 /var/www/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query('MemCacheFactory')

#13 /var/www/owncloud/lib/private/Server.php(1195): OC\ServerContainer->query('MemCacheFactory')

#14 /var/www/owncloud/lib/private/Server.php(593): OC\Server->getMemCacheFactory()

#15 /var/www/owncloud/lib/composer/pimple/pimple/src/Pimple/Container.php(113): OC\Server->OC\{closure}(Object(OC\Server))

#16 /var/www/owncloud/lib/private/AppFramework/Utility/SimpleContainer.php(108): Pimple\Container->offsetGet('AppManager')

#17 /var/www/owncloud/lib/private/ServerContainer.php(86): OC\AppFramework\Utility\SimpleContainer->query('AppManager')

#18 /var/www/owncloud/lib/private/Server.php(1411): OC\ServerContainer->query('AppManager')

#19 /var/www/owncloud/lib/private/legacy/app.php(346): OC\Server->getAppManager()

#20 /var/www/owncloud/lib/private/legacy/app.php(110): OC_App::getEnabledApps()

#21 /var/www/owncloud/lib/base.php(577): OC_App::loadApps(Array)

#22 /var/www/owncloud/lib/base.php(994): OC::init()

#23 /var/www/owncloud/console.php(64): require_once('/var/www/ownclo...')

#24 /var/www/owncloud/occ(11): require_once('/var/www/ownclo...')

#25 {main}

#3

Hey,

this looks to me quite outdated. Maybe you could update to version 10.0.10 or even 10.1.0 and try again?


#4

I wouldn’t dare, to give www-data a shell account. :face_with_raised_eyebrow: