QNAP Deployment. Large downloads fails >4GB files

Hi guys,

I have a QNAP HS-251+ acting as Owncloud server with version 8.2.7. I have a very basic configuration with 2 users in Windows 10 sharing some folders with Desktop Sync client.

The problem is quite simple, very large files give timeout when you downnload trought sync clients. For example, a zip file of 7 GB is uploaded correctly to the server from user1 PC. You can dowload it from Web version but it always timeout from user2 PC via sync client.

Steps to reproduce
1.Upload file bigger than 4GB
2.Download it from Sync client

Expected behaviour
Download works

Actual behaviour
Sync clients give a timeout error. After some troubleshooting, i got conclusion that it always happens when my local file reach about 4GB. It have been tested with different PCs Windows

Server configuration
Operating system: QNAP Linux
Web server: Apache
Database: Mysql
PHP version:
ownCloud version (see ownCloud admin page):8.2.7
Updated from an older ownCloud or fresh install: Updated from 8.0 but it happened also in 8.0
ownCloud log (data/owncloud.log, see https://central.owncloud.org/t/how-to-find-webserver-or-oc-logfile-enable-php-logfile/808): No relevant info in the logs

No special config.

I have tried tuning all timeout and params in the server I have seen over internet but always timeout at 4GB.

Any ideas?



I tried. Also tried chunk size and maxparallels with no results.

Any other ideas?

What kind of timeout messages do you get? From the client or on the server? Normally the client should be less problematic with timeouts due to file chunking.
What client version are you running, and which OS?

I have timeout messages in the desktop client. Windows 10 owncloud 2.2.2. No signal of error in server logs.

Client log:

=#=#=# Syncrun started until (0 msec)

|0|fotos/2015/09.Nuestra_Boda/Camara_JoseMari_Eva/BODA M&M-28-09-2015 10_50_15.zip|INST_NEW|Down|1443435490|7fad396b22f69c7724f00f956f0e5501|5625903594|00124078oceldafiph5f|1|Operation canceled|206|0|0|||INST_NONE|
|0|fotos/2015/09.Nuestra_Boda/Videos/Alexis/635846874539304176.mp4|INST_NEW|Down|1449104568|2fce8be5d6a1945e40e7611d85f5dd68|8435446977|00130022oceldafiph5f|1|Connection Timeout|206|0|0|||INST_NONE|

I have tested same client in other OC instance and it's work. So I suppose it's a problem in the client but originated for some server faulty configuration.

I tested it in another server with same versions and problem doesnt happens. So, my conclussion is that something is happening in the QNAP server that provokes the timeout in the client.

Any ideas?

Comparing both systems and their webserver and/or PHP config might be a starting point. Maybe there are also some QNAP support channels / communities which could also support you if there are any special configs on those NAS systems which could cause this.

Good day! I have exactly the same problem ... files over 4 GB in windows server client is not downloaded, and the windows of the client to the server load. Through the user interface of the web server, and upload and download files to 20 GB. Please help.


its highly discouraged to run ownCloud on a QNAP device for the reasons explained in https://central.owncloud.org/t/upgrade-to-9-1-on-qnap/3803/5 .

They currently can't provide up2date and bugfree system libraries and components. Please do the only sane thing and switch to a recent linux based distro and just use your QNAP as a storage backend via the external storage support app of ownCloud.

I'm closing here to avoid that the thread get further pushed possible unrelated posts / questions.