Several problems with syncing

I installed Owncloud via Dietpi on my Raspberry Pi 4 with a portable hard drive two days ago, and yesterday, everything worked fine. My client pc is a Windows 10 machine and an Android phone.
Windows Client version: 2.6.3 (build 13551)
I’m using virtual files on both.

Today, some problems appeared:

  1. I’ve put lots of files in the cloud. On every start of the OwnCloud client, it checks for changes in every file in the cloud. The message is “Änderungen der entfernten Ressource [filename] werden geprüft” (german for “Changes in the removed/distant resource [filename] are checked”. This uses up 100% of my HDD uptime on my local machine, and my pc gets unresponsive during the whole time. Is this expected? It’s not like this on my phone, where the startup works nearly immediatly.

  2. After the syncing is finished, a shared folder gets all its contents deleted. The client log says “INST_REMOVE|Up|”, but I never touched the local (virtual) files of it. If I restore them via the website, they reappear, only to get deleted after the next sync again. The folder itself stays.

  3. Everytime I start the client, I get another entry of my local HDD in the navigation pane of windows explorer. It looks like this currently: . Is there a way to disable/revert this?

Have you tried reinstalling the client? As this sounds really odd to me.
Can you perhaps create a log for the client and provide it here?