Size of the folder is pending

Expected behaviour
Show folder size

Actual behaviour
Size of the folder is pending

Special configuration (external storage, external authentication, reverse proxy, server-side-encryption):

Integrity status for oC9+

Login as admin user into your ownCloud and access
No errors have been found.

In my owncloud 9.1.0, External Storage whith SMB to windows server, the size is pending.
How to resolve this problem?
If I open the folders the value is updated.


1 Like


make sure that you have installed the libsmbclient-php as described here:

Furthermore you might need to run the following command regularely:


However you should note the following when using "Log-in credentials, save in session":

1 Like

Thanks for your response, but my problem not solved. =(

Another problem is, the folders are SMB / CIFS, when does the check disappear folders in my owncloud, but the folders exist...

Is this a new problem in this version of OC (if you updated from a previous version)?

I installed new server for Appliance in the owncloud website.
Is a bug of the version 9?


No it's just if it were working in ownCloud 9.0, they would have broken something in 9.1. But without comparison, it could be a problem of ownCloud, of your network, of your SMB-storage, ...

I have install e new virtual machine witch owncloud 9.0 and the problem not solved. =(

The subfolders desapear when cron.php run .
I have a windows server 2012 r2 witch virtual machine to run owncloud. The folders to owncloud is my share in my server.

After install owncloud i run this commands to smb authentication works:

apt-get install smbclient
apt-get install libsmbclient-dev
git clone git://
cd libsmbclient-php ; phpize
sudo make install
make install INSTALL_ROOT=/tmp/smbc
vi /etc/php5/apache2/php.ini Add to the file -> extension=""
service apache2 restart

Am I doing something wrong?


If you are still installing and not using it in production, you could try the 9.1.1-release candidate:

they fixed a few things on SMB external storage, especially:

Added conditional trace logging for debugging SMB on productive systems - core/#25758

If the problem then still exists, please open a bug report on

Same problem with v10.0.2.1. Since upgrade from v9.1.6 I was wondering why desktop client showed "0 KB is used" in account tab.

Running occ files:scan made some improvement; now "only" two subfolders aren´t calculated - state "pending". Running occ files:scan for affected user account or even using "--path=/username/files/affected/path" option didn´t fix it.

In MySQL db "select COUNT(fileid) from oc_filecache where size like "-1"" gives 290 entries; most of them exactly in those two affected subfolders.

==> What to do or try next?

No one? Really NO idea? :frowning:


I did. But no response...

Give them some time, it was just 20h ago, or buy an enterprise subscription.