[SOLVED] OC 10.9.1 u/g failed. "wrong" PHP version - even though it isn't

Steps to reproduce

  1. Upgrade OC to 10.9.1
  2. Try to log in on browser
  3. Get the following error message
    This version of ownCloud requires at least PHP 7.3.0
    You are currently running PHP 7.2.34. Please update your PHP version.
  4. Discover via phpMyadmin that PHP 7.3.32 is already running.
  5. Panic

I run Owncloud on a shared server.
I installed it via Softaculous on cPanel.
I upgrade it periodically via Softaculous
Today I upgraded OC to 10.9.1
When I try to access OC at
I get the following message.

This version of ownCloud requires at least PHP 7.3.0
You are currently running PHP 7.2.34. Please update your PHP version.

According to cPanel I am running PHP 7.3.32

So now I cannot access Owncloud at all.

Any suggestions please?
I’m not a Server pro so please use simple language.

I must say that it is pretty disappointing that Owncloud does not check if it thinks the wrong PHP version is running BEFORE it upgrades (and blocks access).


Expected behaviour

I want to be able to see my data

Actual behaviour

I cannot see my data and get an unhelpful error message.

Server configuration

Operating system:

Web server:


PHP version:

ownCloud version: (see ownCloud admin page)

Updated from an older ownCloud or fresh install:
Updated from 10.7.0

Where did you install ownCloud from:
Softaculous on cPanel

Signing status (ownCloud 9.0 and above):

Login as admin user into your ownCloud and access 
paste the results into https://gist.github.com/ and puth the link here.

I cannot log in for the reasons described

The content of config/config.php:

$CONFIG = array (
  'instanceid' => '',
  'passwordsalt' => '',
  'secret' => '',
  'trusted_domains' => 
  array (
    0 => 'DOMAIN.com',
  'datadirectory' => '/data02/DOMAIN/ownclouddata',
  'overwrite.cli.url' => 'https://DOMAIN.com/owncloud',
  'dbtype' => 'mysql',
  'version' => '',
  'dbname' => 'DOMAIN_ownc347',
  'dbhost' => 'localhost',
  'dbtableprefix' => 'oc_',
  'dbuser' => 'DOMAIN_ownc347',
  'dbpassword' => '',
  'logtimezone' => 'UTC',
  'installed' => true,
  'theme' => '',
  'loglevel' => 0,
  'maintenance' => false,
  'integrity.check.disabled' => true,
  'filelocking.enabled' => false,
  'trashbin_retention_obligation' => '60,120',
  'versions_retention_obligation' => 'auto',
  'web.baseUrl' => 'https://DOMAIN.com/index.php/apps/web',

Log in to the web-UI with an administrator account and click on
'admin' -> 'Generate Config Report' -> 'Download ownCloud config report'
This report includes the config.php settings, the list of activated apps
and other details in a well sanitized form.


If you have access to your command line run e.g.:
sudo -u www-data php occ config:list system
from within your ownCloud installation folder

*ATTENTION:* Do not post your config.php file in public as is. Please use one of the above
methods whenever possible. Both, the generated reports from the web-ui and from occ config:list
consistently remove sensitive data. You still may want to review the report before sending.
If done manually then it is critical for your own privacy to dilligently
remove *all* host names, passwords, usernames, salts and other credentials before posting.
You should assume that attackers find such information and will use them against your systems.

List of activated apps:

If you have access to your command line run e.g.:
sudo -u www-data php occ app:list
from within your ownCloud installation folder.

Are you using external storage, if yes which one: local/smb/sftp/…

Are you using encryption: yes/no

Are you using an external user-backend, if yes which one: LDAP/ActiveDirectory/Webdav/…

With access to your command line run e.g.:
sudo -u www-data php occ ldap:show-config
from within your ownCloud installation folder

Without access to your command line download the data/owncloud.db to your local
computer or access your SQL server remotely and run the select query:
SELECT * FROM `oc_appconfig` WHERE `appid` = 'user_ldap';

Eventually replace sensitive data as the name/IP-address of your LDAP server or groups.

Client configuration

FF 96.0.2
Operating system:
Win11 latest


Web server error log

Insert your webserver log here

ownCloud log (data/owncloud.log)

It’s empty

Insert your ownCloud log here

#### Browser log

Insert your browser log here, this could for example include:

a) The javascript console log
b) The network log
c) …


I had a nose round cPanel and found ‘MultiPHP Manager’ and noticed it was still showing PHP 7.2
I clicked the pulldown circled in red below and found 7.3.
When I applied the change the OC 10.9.1 upgrade continued automatically.
I now have access to OC…yippee!


Great you found a solution!
Upgrading PHP is the correct thing to do in this situation.
If possible, upgrade one step further, to PHP 7.4 (but don’t upgrade to PHP-8.x, ownCloud does not like that)

Your point about running the updater until things explode is valid.
We should have checked the dependencies before starting the update.

I’ve reproduced the situation in a clean environment, and filed a bug report

If upgrading PHP is possible in a timely manner, there is also the option to first roll back to ownCloud 10.8 and upgrade PHP later…

1 Like

Thank you for your supportive comments.
I have found the ‘inherit’ option in the pulldown.
I think that will ensure I use the ‘system PHP version’ (shown in big letters as 7.4 in my image above).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.