[SOLVED] OC 10 - Update Market 0.2.5 auf 0.3.0 meldet "Die App kann nicht installiert werden, weil sie unerlaubten Code enthält"

help

#1

Hallo,

habe eine Fehlermeldung beim Update der Market “App” von Version 0.2.5 auf 0.3.0 unter Market=>Updates.

Woran kann es liegen?

Die Owncloud 10.0.10 läuft unter Fedora 29 - Linux auf einem Apache httpd mit mariadb.

PHP 7.2.13

Owncloud 10 habe ich manuell über die 9.1.5 von Fedora installiert, die von Fedora leider nicht mehr gepflegt wird.

Signing Status: "No errors have been found."

{
    "system": {
        "log_type": "owncloud",
        "logfile": "\/var\/log\/owncloud.log",
        "loglevel": 2,
        "datadirectory": "\/var\/lib\/owncloud\/data",
        "updatechecker": true,
        "check_for_working_htaccess": false,
        "asset-pipeline.enabled": false,
        "assetdirectory": "\/var\/lib\/owncloud",
        "preview_libreoffice_path": "\/usr\/bin\/libreoffice",
        "apps_paths": [
            {
                "path": "\/usr\/share\/owncloud\/apps",
                "url": "\/apps",
                "writable": false
            },
            {
                "path": "\/var\/lib\/owncloud\/apps-external",
                "url": "\/apps-external",
                "writable": true
            }
        ],
        "instanceid": "***REMOVED SENSITIVE VALUE***",
        "passwordsalt": "***REMOVED SENSITIVE VALUE***",
        "secret": "***REMOVED SENSITIVE VALUE***",
        "trusted_domains": [***REMOVED SENSITIVE VALUE***],
        "overwrite.cli.url": "https:\/\/localhost\/owncloud",
        "appcodechecker": true,
        "dbtype": "mysql",
        "version": "10.0.10.4",
        "dbname": "owncloud",
        "dbhost": "localhost",
        "dbtableprefix": "oc_",
        "dbuser": "***REMOVED SENSITIVE VALUE***",
        "dbpassword": "***REMOVED SENSITIVE VALUE***",
        "default_language": "de_DE",
        "installed": true,
        "forcessl": true,
        "mail_from_address": "***REMOVED SENSITIVE VALUE***",
        "mail_smtpmode": "php",
        "theme": "",
        "maintenance": false,
        "memcache.local": "\\OC\\Memcache\\APCu",
        "filelocking.enabled": true,
        "trashbin_retention_obligation": "auto",
        "htaccess.RewriteBase": "\/owncloud",
        "mail_smtpauthtype": "LOGIN",
        "mail_smtpauth": 1,
        "mail_smtphost": "***REMOVED SENSITIVE VALUE***",
        "mail_domain": "***REMOVED SENSITIVE VALUE***"
    }
}

“Apps”:
Enabled:

  • activity: 2.4.1
  • announcementcenter: 1.2.1
  • brute_force_protection: 1.0.1
  • calendar: 1.6.1
  • comments: 0.3.0
  • configreport: 0.1.1
  • contacts: 1.5.5
  • dav: 0.4.0
  • federatedfilesharing: 0.3.1
  • files: 1.5.1
  • files_external: 0.7.1
  • files_pdfviewer: 0.10.0
  • files_sharing: 0.11.0
  • files_texteditor: 2.3.0
  • files_textviewer: 1.0
  • files_trashbin: 0.9.1
  • files_versions: 1.3.0
  • files_videoplayer: 0.9.8
  • firstrunwizard: 1.1
  • market: 0.2.5
  • notes: 2.0.4
  • notifications: 0.3.5
  • polls: 0.8.1
  • systemtags: 0.3.0
  • tasks: 0.9.7
  • updatenotification: 0.2.1
    Disabled:
  • encryption
  • external
  • federation
  • provisioning_api
  • user_external

Kein external storage, keine Verschlüsselung.

Ich nutze die OC mit Webdav, keine anderen externen Frontends.

Browser: SeMonkey 2.49.1

Remote Operating system: Windows 10

Im webserver log keine diesbezüglich relevanten EInträge.

owncloud.log:
{"reqId":"XDCQaLh@4ci0ISnG3cXiOgAAAAs","level":3,"time":"2019-01-05T11:09:31+00:00","remoteAddr":"*.*.*.*","user":"root","app":"PHP","method":"POST","url":"\/owncloud\/index.php\/apps\/market\/apps\/market\/update","message":"Undefined variable: undefinedVariable at \/usr\/share\/owncloud\/lib\/composer\/nikic\/php-parser\/lib\/PhpParser\/Lexer.php#70"}
{"reqId":"XDCRgP0I8OPZovhwjjTfGQAAAMg","level":3,"time":"2019-01-05T11:14:11+00:00","remoteAddr":"*.*.*.*","user":"root","app":"PHP","method":"POST","url":"\/owncloud\/index.php\/apps\/market\/apps\/market\/update","message":"Undefined variable: undefinedVariable at \/usr\/share\/owncloud\/lib\/composer\/nikic\/php-parser\/lib\/PhpParser\/Lexer.php#70"}

Danke! :slight_smile:

Gruß
Frank


#2

Das ist sehr seltsam. Hab die Frage an unseren Experten weitergeleitet.


#3

Prima, Danke … bin gespannt! :+1:


#4

Das bitte auf false setzen!


#5

Hatte ich auch schon überlegt, funktioniert aber leider nicht.
=> In config.php " ‘updatechecker’ => false,"
Trotz Restart httpd und sogar Reboot des Servers … immer die gleiche Fehlermeldung. :tired_face:
Kann ich Market 0.3.0 auch noch “zu Fuß” wie früher installieren?


#6

Ich hab die falsche Zeile kopiert! :face_with_hand_over_mouth:

‘appcodechecker’ => false,


#7

Und schon klappt’s. Prima, Danke für die schnelle und kompetente Hilfe!!! :+1:
Ist der updatechecker denn nun ein relevantes Sicherheitsfeature oder “darf” ich den dauerhaft auf false setzen?


#8

… meinte natürlich den appcodechecker … :wink:


#9

Wir werfen den app code checker in 10.1 komplett raus. Kann also dauerhaft auf false gesetzt werden (ist auch der default :wink: )