Solved "Server not found" issue on IOS10

I have my own 9.0.4 installation, and it has been working perfectly on OSX 10 and various Androids, but today I installed the client in my IOS 10 iPhone, and I only got "server not found". After some troubleshooting I found that the IOS client was requesting '/status.php' from the webserver, and not /owncloud/status.php as it should have done. I linked the owncloud status.php into the location from client app request, and now it connected fine. I had to do the same with remote.php to Get authentication to work. From then on the Owncloud IOS client worked perfectly.

I guess it should be addressed from within the client, but how?


i don't think that this needs to be solved at all within the client. If the iOS client has requested /status.php and not /owncloud/status.php you probably have configured a wrong base url to your oC instance within the client.

I agree!
I simply made the mistake of not adding the whole path to the connecting server.

so im having the same promblem
what url do i supply in the phone

You have to put in the URL to your ownCloud instance, e.g. or

im trying to use the ios app
it keeps saving server not found

Then stick on your newly created issue instead of pushing an older thread in parallell.

maybe someone could help instead of hindering

This is not about hindering but about letting you know that you're causing doubled work and confusion for the people helping in here in their free time...

Just a short (and i hope it is not a stuppid) question: Do i have to add in the iOS OC App "status.php" or "remote.php" after the URL of our OC? Or where do i have to do this? Thanks for your help!

@MartinMuellerMM, you do not need to enter status.php neither remote.php, the iOS client will added later.

What you need to enter is the URL to your ownCloud instance as @anon81984126 said here

@leemajors if you still have some issue tring to login you can open a new issue on the iOS repository with more details, thanks!

Thanks and sorry, i was in the wrong issue ... i have the problem that there is "waiting on server connection" when trying to upload from iOS ...