Sync all set, yet folder isn't being synced because it is blacklisted?


#1

Expected behaviour

The folder shows up as a choice to sync.

Actual behaviour

Folder never shows as a choice -- quitting and re-opening the client doesn't refresh the folder list to show the added folder.

Steps to reproduce

  1. Copy folder into the owncloud folder. (Same user permissions)
  2. Wait for the folder to sync or at least get recognized by the owncloud client.
  3. Folder never shows up as a "choice" to sync or not but "activity -> not synced" reports folder is blacklisted.

Server configuration

Operating system:
CentOS 7.4

Web server:
Apache

Database:
sqlite

PHP version:

ownCloud version:
9.1.5
Storage backend (external storage):

Client configuration

Client version:
2.4.1 (build 9367)

Operating system:
MacOS 10.14.3

OS language:
English

Qt version used by client package (Linux only, see also Settings dialog):

Client package (From ownCloud or distro) (Linux only):

Installation path of client:

Logs

Please use Gist (https://gist.github.com/) or a similar code paster for longer
logs.

Template for output < 10 lines

  1. Client logfile: Output of owncloud --logwindow or owncloud --logfile log.txt
    (On Windows using cmd.exe, you might need to first cd into the ownCloud directory)
    (See also http://doc.owncloud.org/desktop/2.2/troubleshooting.html#client-logfile )

  2. Web server error log:

  3. Server logfile: ownCloud log (data/owncloud.log):


#2

One thing to note: The folder used to exist in owncloud but was deleted a while back. The folder I'm attempting to copy back into the owncloud folder was restored from backup.


#3

I fixed this by creating the folder via the owncloud web interface. It then showed up as a choice I could sync on the client so I moved my backed up copy out of the owncloud folder, enabled the folder in the client so that it would syn,c and then moved my folder back into the owncloud folder.

I guess there was some stale data somewhere? With the client?