The exact error message was: cURL error 7: Failed to connect to localhost port 9980: Connection refused

hosting

#1

when i try to open a word file in my owncloud folder, it comes
"Collabora Online: Cannot connect to the host "https://localhost:9980". Please ask your administrator to check the Collabora Online server setting. The exact error message was: cURL error 7: Failed to connect to localhost port 9980: Connection refused"
thanks a lot if anyone can help me work it out


#2

Hi,

Do you use the appliance?


#3

it’s passed one year and i have the same problem…any solution?


#4

Can you provide more info to your problem?


#5

i have the same problem…on github i contact the developer of app.

seem missing code collabora installing…but it’s very hard found update tutorial to install without docker


#6

Okay, that does not provide anything new.

Can you provide specific information about your problem so people can try to fix it?


#7

i haven’t docker i follow this istruction https://www.collaboraoffice.com/code/

but when i launch the last line i have this error

W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:6 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:6 W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:7 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:7 W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:8 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:8 E: The method driver /usr/lib/apt/methods/https could not be found. N: Is the package apt-transport-https installed? E: The method driver /usr/lib/apt/methods/https could not be found. N: Is the package apt-transport-https installed? E: Failed to fetch https://www.collaboraoffice.com/repos/CollaboraOnline/CODE-ubuntu1804/./InRelease E: Failed to fetch https://www.collaboraoffice.com/repos/CollaboraOnline/CODE/./InRelease E: Some index files failed to download. They have been ignored, or old ones used instead. W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:6 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:6 W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:7 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:7 W: Target Packages (Packages) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:8 W: Target Translations (en) is configured multiple times in /etc/apt/sources.list:5 and /etc/apt/sources.list:8


#8

can you clean your sources.list? There are many error messages


#9

Collabora Online: Cannot connect to the host “https://localhost:9980”.

Please ask your administrator to check the Collabora Online server setting. The exact error message was: cURL error 7: Failed to connect to localhost port 9980: Connection refused

when going to collabora after install

“:“Undefined index: filename at /var/www/html/owncloud/apps/richdocuments/controller/documentcontroller.php#390”}
{“reqId”:“0EjXeXfBNBy0zdr2wYgJ”,“level”:3,“time”:“2018-09-21T20:42:36-04:00”,“remoteAddr”:“192.168.1.9”,“user”:“xxxxx”,“app”:“PHP”,“method”:“POST”,“url”:”/index.php/apps/richdocuments/ajax/documents/create",“message”:“Undefined index: dir at /var/www/html/owncloud/apps/richdocuments/controller/documentcontroller.php#391”}


#10

can you try to configure a dns name for your ownCloud installation, and point collabora to that?

I don’t know if it works with localhost, like in your installation.


#12

are you refering to db_host or redis

‘redis’ =>
array (
‘host’ => ‘localhost’,


#13

No I mean DNS.

You are accessing your instance right now with localhost something.

What you can do is map your IP to a domain name in your /etc/hosts file.

Like: 192.168.3.1 mysupermegagoodserver.com

So if you type in your browser mysupermegagoodserver.com you get redirected to 192.168.3.1


#14

Isn’t /etc/resolv.conf who handles that.

Anyhow i will try pointing my host to my dns