This version of ownCloud is not compatible with PHP 7.3

same issue is here.i am very upset

Where did this update/upgrade came from. Have not seen a mention or warning, nor have I been asked to install it? I did not do an update or upgrade on the raspi. Is there some small print in the user license for owncloud that makes this possible?

Actually, I tried this and it does not work on my raspi 3b running raspbian buster.
I have no idea why it “just” does not work. Commented out the checks in /var/www/owncloud/ on both index.php and console.php and restarted nginx.
If there are new insights on how to work with 2 versions of php-fpm I am glad to hear/read them.

tia,
peter

For Debian and Ubuntu based installation use this. With it you should be able to install any PHP version you might need.

1 Like

You are very optimistic. Needed sudo apt-get install software-properties-common
Tried to install the PPA, but: sudo add-apt-repository ppa:ondrej/php came back with a python error.
Traceback (most recent call last):
File “/usr/bin/add-apt-repository”, line 95, in
sp = SoftwareProperties(options=options)
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 109, in init
self.reload_sourceslist()
File “/usr/lib/python3/dist-packages/softwareproperties/SoftwareProperties.py”, line 599, in reload_sourceslist
self.distro.get_sources(self.sourceslist)
File “/usr/lib/python3/dist-packages/aptsources/distro.py”, line 93, in get_sources
(self.id, self.codename))
aptsources.distro.NoDistroTemplateException: Error: could not find a distribution template for Raspbian/buster

Ah sorry, ARM builds are something else, you might have to compile yourself.

1 Like

Good news! I was unsuccessful to install the PPA from deb.sury.org. What I did was performing the instructions found in his wiki on Managing Multiple Versions by hand:
> sudo update-alternatives --set php /usr/bin/php7.2
update-alternatives: using /usr/bin/php7.2 to provide /usr/bin/php (php) in manual mode
> sudo update-alternatives --set php-config /usr/bin/php-config7.2
> sudo update-alternatives --set phpdbg /usr/bin/phpdbg7.2
update-alternatives: error: alternative /usr/bin/phpdbg7.2 for phpdbg not registered; not setting
> sudo update-alternatives --set phpize /usr/bin/phpize7.2

After these instruction the world seemed unchanged and I decided to wait it out.
Yesterday I needed my Pi for something and switched it on again. My xubuntu computer suddenly asked me for the OwnCloud password. I was amazed, but OwnCloud was working again. I checked the PHP version it is working on now and it was the former version 7.2.
My problem is solved for now!:sweat_smile:

1 Like