[ubuntu16.04] owncloud client not supported by owncloud server 10.0.3

After owncloud server upgrade from 9.1.6 to 10.0.3 (the so called owncloud X) the ubuntu 16.04 client can not connect to the server. The error is: "Error downloading https://SERVERNAME/owncloud/remote.php/webdav/ - server replied: Forbidden (Unsupported client version.)". Please upgrade ASAP the owncloud client. It is not possible patch by adding ''deb https://download.opensuse.org/repositories/isv:/ownCloud:/desktop/Ubuntu_16.04/' repository.
Thank you very much.

ProblemType: Bug
DistroRelease: Ubuntu 16.04
Package: owncloud-client 2.1.1+dfsg-1ubuntu1.1
ProcVersionSignature: Ubuntu 4.4.0-96.119-generic 4.4.83
Uname: Linux 4.4.0-96-generic x86_64
ApportVersion: 2.20.1-0ubuntu2.10
Architecture: amd64
CurrentDesktop: Unity
Date: Wed Sep 20 00:31:42 2017
InstallationDate: Installed on 2016-04-27 (510 days ago)
InstallationMedia: Ubuntu 16.04 LTS "Xenial Xerus" - Release amd64 (20160420.1)
SourcePackage: owncloud-client
UpgradeStatus: No upgrade log present (probably fresh install)

I think your 2.1.1 version of the client is too old as stated in the "Unsupported client version" message.

You are right but it was impossible to upgrade the client. See https://central.owncloud.org/t/repository-bug-on-ubuntu-16-04/9546/4.

1 Like

I have the same problem.
There is an option in config.php to define a minimum client version (from the admin manual):
minimum.supported.desktop.version’ => ’2.1.1’

Does anybody know if this will work or lead to problems?
What ist the official minimum client version of 10.0.3-server?

2.1.1-client was fine with 10.0.2-server. IMHO a minor version change should not force the client to change.

BTW: The admin manual for version 10 states that ubunto 16.04 is recommended. This might be true for the server side. But should be for the client side, too. At least until Ubuntu 18.04 LTS will be released.

1 Like

-> Default minimum desktop client version in config.php is now 2.2.4.

I think you shouldn't use anything below that as there are probably reasons why this is enforced.

Is there a solution in the meantime? I run ownCloud desktop client on ubuntu 16.04 and I can not update the desktop client which has the version 2.2.3

1 Like

Download the cliet using this page: https://owncloud.com/download/

@marco.righi @Plastikschnitzer @Der_Anwender try to clean the traces of previous installations from different mirrors to avoid installation issues, see: https://github.com/owncloud/client/issues/6034#issuecomment-329753354

1 Like

This does not give me a compatible version thou.
Using Debian 8.

I use ubuntu 16.04 64 bit

Is there a solution for debian 8 then?

I've installed the client on ubuntu 16.04 according to https://owncloud.com/download/.
Good news: The client on my system shows up as version 2.3.3
Bad news: the package nautilus-owncloud refuses to install. Any solutions to this one?
UPDATE/SOLUTION: The package owncloud-client-nautilus works as intended!

For now, I told the 10.0.3-Server to accecpt clients from version 2.1.1 and higher.
It works fine.
Please confirm or critisize the following reasoning:
10.0.3 is a webdav-compatible server. Any webdav-client can connect to it. Since oC-client 2.1.1 is a webdav-client, there is no reason why this client-server-combination should not work - unless one of them is buggy. And even in the case the client is buggy, the server should be able to handle it. Or at least the server should be able to protect its data from loss or corruption.

I guess the owncloud sync client is more then a simple "webdav-client" and there are most likely strong reasons why such a newer version is enforced. Until you want to shoot yourself into your feed :slight_smile: its probably strongly discouraged to use such outdated version like 2.1.1

1 Like

We have just installed the latest versions of both owncloud server and client. When installng the desktop client in MacOs it works as expected. But when doing so in another machine with Ubuntu 16.4 we are getting the same error (unsupported client version). We have downloaded everything from https://owncloud.org/download/. Is there any bug in the Ubuntu version or are we missing anything? Thanks

I think the chances that this is true is very high. You probably still getting the 2.1.1 client directly from Ubuntu 16.04 rather then the expected 2.4.0 from the ownCloud repositories. Maybe the following command is telling you more and helping you to correctly setup the repositories to get a newer version:

apt-cache policy owncloud-client

Thanks Tom, you are right. When running the command I can see that the installed version was 2.1.1. We have tried installing everything again adding the repositories instead of downloading the binary file and it works.

Thanks again

1 Like