Unable to activate a new Vmware Owncloud Appliance after deleting the old one


#1

I am new to Owncloud so I hope this makes sense.

I downloaded the latest Univention-App-owncloud-ESX.ova file and deployed it to my VMware infrustructure.
I setup Owncloud to join our 2008r2 active directory domain as a Domain controller backup and that worked. I received the activation license and all was well. Then I ran into issues with the users not showing up properly in Owncloud from Active Directory. I took a look at the logs and noticed a user account was causing an issue due to spaces in the name. I deleted the account as I didn't need that account anymore but I still could not get the users from AD to show up in Owncloud. Only a few would show. I decided to delete the Owncloud server and start over. The issue I am having now is that I can not complete the system configuration of the new server as it is saying that "to install the owncloud appliance it is necessary to have an activated license on the master controller. During the check of the license status the following error occurred: ssh: connect to host hostname.local port 22 connection refused.

I did setup a ssh server on the main DC then it gives me a man in the middle warning but it still won't let me finish the setup. If there is someone that could reset the activation of the old server that would be great too. Then at least I could see if the issues with user replication has been fixed.

Any and all help would be appreciated. This is just a test environment to see if Owncloud is right for us and we may end up buying support if we see this could be a good fit.

Thanks


#2

That sounds like an Active Directory / Univention issue.

If you connect your Appliance to your AD many things are created. You have to delete all the old entries before you can connect the new Appliance to the same AD.


#3

I see ok would you by chance have a link to a article on that or a list of entries that need to be deleted? I did delete the computer account for it but haven't found any other entires so far.


#4

Can you check the DNS entries?

I had a similar issue, and I had to clear the DNS entries of the old appliance


#5

Dmitry you're the Man that is exactly what it was. Thank you very much for the help! I will see if I can get my users to show up in Owncloud now after the setup finishes. Hopefully it works. I will let you know how it goes. Thanks again


#6

You need to run the user:sync command for the users to show up in owncloud

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/occ_command.html#ldap


#7

Thanks dmitry. having some issues with syntax. I am not sure how I need to modify this to work on my system. I am not really a Linux guy. sudo -u www-data ./occ user:sync "OCA\User_LDAP\User_Proxy" Any help is appreciated.


#8

Go to your owncloud directory
Like /var/www/owncloud/
This you can do with cd
Then run
sudo -u www-data php occ user:sync "OCA\User_LDAP\User_Proxy"

Or sudo -u www-data php occ user:sync -l
To see what backends are available


#9

I am stuck trying to find my owncloud directory. It isn't in /var/www/ Is there somewhere in the config's that will tell me the path?


#10

Sorry, I forgot that you are using the appliance... my bad

You are probably on the host system, you have to go into the container to execute the owncloud command.

Execute this to enter the container:
univention-app shell owncloud

there you will have to execute the user:sycn commands from my previous post, but you can leave the sudo -u www-data php out.

So like this:

occ user:sync "OCA\User_LDAP\User_Proxy"


#11

Thanks haha I have been thinking I am blind over here. When I try and run that it says "cannot run command : owncloud is not running in a container". I am running the appliance thou.


#12

what is the output of

docker ps ?

you can also try

univention-app shell owncloud82

if you are not running a container - you don't have owncloud yet. Maybe something went wrong with the setup - in that case I would reinstall.


#13

says "cannot connect to docker daemon. Is the docker daemon running on this host?"
tried owncloud82 and got the same message as before.


#14

Yeah... that's bad.

Can you try

univention-app install owncloud ?

if this does not work - uninstall - install again. Or restore a snapshot if you have one


#15

I just looked in installed applications and you are absolutely correct. I just assumed it would have installed like it did before.


#16

Sorry Dmitry I feel like I wasted your time. Installing owncloud 10.0.3 now


#17

No :smiley:

I am glad to be able to help people like you.

And I have been working on the appliance for several months, so I am very interested in assuring that it works.


#18

Thanks I appreciate the help :slight_smile: I will let you know how it goes after the install.


#19

I hope everything goes well :slight_smile:

Can you tell me why you want the appliance to work as a backup domain controller?
I have never seen the appliance to be used in that way.


#20

I am going to start over as things still don't seem to be working right. I honestly don't know if this is the right model for us. basically what we are looking for is a cloud storage solution that we can utilize single signon / ad service for the users to login and access their cloud data. If there is a better model/setup we should use please advice. I just chose the backup DC controller so credentials would be unified across seamlessly. I am back on Monday so I will respond to your reply when I return. Thanks dmitry