Unable to set user email (OC 9.1.4) - 403 forbidden

9.1.x

#1

Hello,
i'm using owncloud 9.1.4 in a openmediavault 3 install
i'm the admin user of the server and when I try to add an email adress for users, the browser show me the wheel turning and returns the following errors (with Firefox developer tools)

in the console : TypeError: result.responseJSON is undefined

in the network : PUT request 403 : forbidden

I set strong permissions as indicated in the owncloud admin doc
The datas are stored on a Raid mirror drive located on /media/.../owncloudData and I've linked the /var/www/owncloud/data to that folder
Permissions on both folder and file are set as follow:
owner : www-data
group : www-data

Last but not least (perhaps?) I initially setup owncloud with the standard SQLite and then migrated to mysql

If someone can help me solve that issue, that would be great.

Thanks.

Server configuration
Operating system: OpenMediaVault 3.0.67
Web server:Nginx 1.6.2
Database: MySQL 5.5.54-0+deb8u1
PHP version: PHP 5.6.30-0+deb8u1
ownCloud version : 9.1.4


#2

Hi,

this is unrelated to the permission on the harddisc and means that your webserver configuration doesn't allow the "PUT" HTTP Verb.


#3

Thanks a lot
i'll try the change tomorrow. Should I change owncloud specific config file or general nginx config file?


#4

This is an issue within your nginx / webserver config, not allowing this specific method.


#5

Hello 'k'
I did allowed the PUT method in my nginx/owncloud config
I reloaded (and then stop/start) the nginx config but it didn't changed anything. I'm still having this 403 / forbidden error

I added: dav_methods PUT; to the location / directive
the root was already set as /var/www/owncloud/ (which my root install dir)

is it a wrong way to allow as I did? How can I be sure the method is enable?

Any other ideas?
Thanks


#6

There shouldn't be any of such directives / stuff about DAV in your servers config.

How you need to configure this heavily depends on your used webserver, added includes (e.g. by your linux distro) or by other additional security modules within your webserver.

If you won't get any answers here (which can happen as this doesn't look like an ownCloud issue) you could choose one of the support options of nginx listen here: https://www.nginx.com/support/