Update 10.5 to 10.6 errors - Unable to write to folders

Server: CentOS 7
ownCloud: 10.5.0.10

Hosted on Apache webserver.

Hi,

I am trying to run the update from 10.5 to 10.6, but I keep getting this error:

image

I am running the update from my own account, which has admin rights in ownCloud.
The /var/www/html/owncloud and all subfolders have apache:apache permissions, as advised in the installation documentation.

SELinux is disabled but made no difference.

Is there something else I need to change, which would be strange for an updater that is designed to be an easy process?

Any thoughts and advice welcomed.

Cheers.

Absolutely double check that you have the correct permissions by posting the output of:

  • ls -alZ /var/www/html/owncloud

As root you could try to run the following to narrow down on the issue:

  • sudo -u apache touch /var/www/html/owncloud/test
  • sudo -u apache touch /var/www/html/owncloud/core/test

Obviously remove the files after a successful test, otherwise post the error message.

1 Like

In case you are using php-fpm make sure /var/www/html/owncloud has got the fpm-user permissions

1 Like

HI,

As requested:

Output:

I don’t know if these are what was expected or not?
Do I need to change the permissions to apache:apache?
(I thought that was the setting already applied to the ownCloud folder and all subfolders & files.)

As you can see, I am signed into the ssh as root. If I do the second test, I get the following:

I assume this is to do with root creating the folder and not apache. Is this why the folders all say root:apache in the dir listing above?

Sorry cortho, how do I check to see if I am using php-fpm?
Is this specific to ownCloud or generic to the whole server?
Would a PHP-Info page return that information?

Any further support is most welcomed.

Cheers.

The -Z in ls tells you the system context for SELinux. The ? is the column with the system context.

User ownership root is wrong, so set it apache:apache like you said.

Thanks.
I ran:
chown -R apache:apache /var/www/html/owncloud
as root which reset all the permissions correctly and the updater has now run.

Why the permissions had been changed, I am not sure, but thanks for the assistance.

Cheers.

1 Like