Update 9.1.x to 1.0.3 internal server error 500


#1

Hello,

after upgrade from version 9.1.x to 10.0.3 there is an internal server error 500

in the apache2 logs I have

"AH00124: Request exceeded the limit of 10 internal redirects due to probable configuration error. Use 'LimitInternalRecursion' to increase the limit if necessary. Use 'LogLevel debug' to get a backtrace."

I suppose it's a problem with htaccess, My system is ubuntu 14.04 LTS with all updates.
php "php -v
PHP 7.2.3-1+ubuntu14.04.1+deb.sury.org+1 (cli) (built: Mar 6 2018 12:03:48) ( NTS )
Copyright (c) 1997-2018 The PHP Group
Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
with Zend OPcache v7.2.3-1+ubuntu14.04.1+deb.sury.org+1, Copyright (c) 1999-2018, by Zend Technologies"

can I ask for help in solving the problem?

Best Regards


#2

I think ownCloud 10.0.3 (which is not the latest available version) is not compatible with PHP 7.2. You probably need to update to the latest available version 10.0.7 and retry if this solves your issue.


#3

this is my htaccess




SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION


SetEnvIfNoCase ^Authorization$ "(.+)" XAUTHORIZATION=$1
RequestHeader set XAuthorization %{XAUTHORIZATION}e env=XAUTHORIZATION


SetEnvIfNoCase Authorization "(.+)" HTTP_AUTHORIZATION=$1


# Add security and privacy related headers
Header set X-Content-Type-Options "nosniff"
Header set X-XSS-Protection "1; mode=block"
Header set X-Robots-Tag "none"
Header set X-Frame-Options "SAMEORIGIN"
Header set X-Download-Options "noopen"
Header set X-Permitted-Cross-Domain-Policies "none"
SetEnv modHeadersAvailable true

# Let browsers cache CSS, JS files for half a year

Header set Cache-Control "max-age=15778463"

# Let browsers cache WOFF files for a week

Header set Cache-Control "max-age=604800"


php_value always_populate_raw_post_data -1
php_value upload_max_filesize 513M
php_value post_max_size 513M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8'
php_value output_buffering 0

SetEnv htaccessWorking true


php_value upload_max_filesize 513M
php_value post_max_size 513M
php_value memory_limit 512M
php_value mbstring.func_overload 0
php_value default_charset 'UTF-8'
php_value output_buffering 0

SetEnv htaccessWorking true


RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.*) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
RewriteRule ^(?:.|autotest|occ|issue|indie|db_|console).* - [R=404,L]


AddType image/svg+xml svg svgz
AddEncoding gzip svgz


DirectoryIndex index.php index.html

AddDefaultCharset utf-8
Options -Indexes

ModPagespeed Off

DO NOT CHANGE ANYTHING ABOVE THIS LINE

ErrorDocument 403 //core/templates/403.php
ErrorDocument 404 //core/templates/404.php

Options -MultiViews
RewriteRule ^core/js/oc.js$ index.php [PT,E=PATH_INFO:$1]
RewriteRule ^core/preview.png$ index.php [PT,E=PATH_INFO:$1]
RewriteCond %{REQUEST_FILENAME} !.(css|js|svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$
RewriteCond %{REQUEST_FILENAME} !core/img/favicon.ico$
RewriteCond %{REQUEST_FILENAME} !/remote.php
RewriteCond %{REQUEST_FILENAME} !/public.php
RewriteCond %{REQUEST_FILENAME} !/cron.php
RewriteCond %{REQUEST_FILENAME} !/core/ajax/update.php
RewriteCond %{REQUEST_FILENAME} !/status.php
RewriteCond %{REQUEST_FILENAME} !/ocs/v1.php
RewriteCond %{REQUEST_FILENAME} !/ocs/v2.php
RewriteCond %{REQUEST_FILENAME} !/updater/
RewriteCond %{REQUEST_FILENAME} !/ocs-provider/
RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
RewriteRule . index.php [PT,E=PATH_INFO:$1]
RewriteBase /chmura

SetEnv front_controller_active true

DirectorySlash off


===================================================


RewriteEngine on
RewriteRule .* - [env=HTTP_AUTHORIZATION:%{HTTP:Authorization}]
RewriteRule ^.well-known/host-meta /public.php?service=host-meta [QSA,L]
RewriteRule ^.well-known/host-meta.json /public.php?service=host-meta-json [QSA,L]
RewriteRule ^.well-known/carddav /remote.php/dav/ [R=301,L]
RewriteRule ^.well-known/caldav /remote.php/dav/ [R=301,L]
RewriteRule ^remote/(.*) remote.php [QSA,L]
RewriteRule ^(?:build|tests|config|lib|3rdparty|templates)/.* - [R=404,L]
RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
RewriteRule ^(?:.|autotest|occ|issue|indie|db_|console).* - [R=404,L]

when # this code, error 500 disappears, the owncloud page then displays "access blocked"


#4

I'm not sure if you have seen my response above?


#5

Hello, problem is solved,

> Options -MultiViews
> RewriteRule ^core/js/oc.js$ index.php [PT,E=PATH_INFO:$1]
> RewriteRule ^core/preview.png$ index.php [PT,E=PATH_INFO:$1]
> RewriteCond %{REQUEST_FILENAME} !.(css|js|svg|gif|png|html|ttf|woff|ico|jpg|jpeg)$
> RewriteCond %{REQUEST_FILENAME} !core/img/favicon.ico$
> RewriteCond %{REQUEST_FILENAME} !/remote.php
> RewriteCond %{REQUEST_FILENAME} !/public.php
> RewriteCond %{REQUEST_FILENAME} !/cron.php
> RewriteCond %{REQUEST_FILENAME} !/core/ajax/update.php
> RewriteCond %{REQUEST_FILENAME} !/status.php
> RewriteCond %{REQUEST_FILENAME} !/ocs/v1.php
> RewriteCond %{REQUEST_FILENAME} !/ocs/v2.php
> RewriteCond %{REQUEST_FILENAME} !/updater/
> RewriteCond %{REQUEST_FILENAME} !/ocs-provider/
> RewriteCond %{REQUEST_URI} !^/.well-known/acme-challenge/.*
> RewriteRule . index.php [PT,E=PATH_INFO:$1]
> RewriteBase /chmura

it was enough to change the line "RewriteBase /chmura" to "RewriteBase /" :stuck_out_tongue:

Best Regards