Update from 10.0.2 to 10.0.8 and Some files have not passed the integrity check


#1

Hello

I use Owncloud v.10.02 for several months, installed on my web host (in a subdomain), with Softaculous apps installer.

For a few weeks I noticed that on the server, the total volume was increasing and I realized that even if my Owncloud contained only 40 GB of files, when I went to see in the CPanel with the file manager, the directory ownclouddata exceeded more than 382 GB.

Suspecting that it was a problem with the contents of some “files_trashbin” directories, I tried to read a little about it, but I thought it was probably time to update my owncloud to version 10.0.8.

Tonight I made an update (with Softaculous) to Owncloud 10.0.8

So here I am with the update installed and when I go on the web server, I have the following messages that is required actions:

I’m going to spend hours of fun to find ways to make these corrections in my config.php ???

And my ownclouddata dir still exceeded more than 382 GB ??? Why…


Security & setup warnings

 Transactional file locking is disabled. Enable 'filelocking.enabled' in config.php to avoid these problems. See the documentation for more information.

 Some files have not passed the integrity check. Further information on how to resolve this issue. (List of invalid files ... / Rescan ...)

 The "Strict-Transport-Security" HTTP header is not configured to at least "15552000" seconds. For enhanced security we recommend HSTS as described in our security tips.

 No memory cache has been configured. To enhance your performance please set up a memcache if available. Further information can be found in our documentation.

Please double check the installation guides, and check for any errors or warnings in the log.


#2

Hi,

Please have a look at the ownCloud documentation.

https://doc.owncloud.com/server/10.0/admin_manual/configuration/server/security_setup_warnings.html?highlight=warnings


#3

I think additional to the documentation you probably need to check in the data directory where the huge size is coming from. Without this information its probably not possible to answer the “382 GB ??? Why…”