Update from 10.0.3 doesn't work


#1

Hi,

Here is a running ownCloud Community instance version 10.0.3.3 (not installed by me) and it should be upgraded to the latest version. I’ve FTP access, but no SSH. PHP Version is 5.6.36.

Admin web interface -> Settings -> Admin/General: When I click on “Open updater”, I’m getting as response:

“cURL error 7: Failed to connect to localhost port 443: Connection refused”

From the Config.php:

‘trusted_domains’ =>
array (
0 => ‘’,
1 => ‘localhost’
),

The second entry has been added by me, without success.

So, I’ve no idea whats the problem and how to solve it. Can anyone help me?


#2

Hosted environments are known to block certain ports / protocols.

I would ask the support of the server hoster to help you out.


#3

Maybe you can manually install the update without using the updater app?


#4

don’t think so :slight_smile:


#5

Mhhh, why not? :slightly_smiling_face:

From what i know its still possible to:

  1. Disable all custom apps
  2. Remove all existing files expect the /data folder and the /config/config.php
  3. Upload the new files via FTP
  4. run the update routine via browser

or am i wrong?


#6

You would be correct if he would got an error during the upgrade with something like

“please disable the following apps and then proceed with the upgrade”

but at that point his instance would be in maintenance mode and without ssh access, even if he just edited the config php and set the variable of maintenance mode to false, his ownCloud would still be in a upgrade state.

So your solution is something that one could do before the upgrade to eliminate the possibility for that situation.
I have proposed to integrate that in the documentation, but got stuck on gathering the information which apps should be disabled. So I proposed a warning or a check, that looks for your apps that are enabled and warns you before making the upgrade in the web UI. I hope someone is working on this and that it will be in one future releases as it’s a common pitfall that new users fall in to and get frustrated and consider a change of software.

what he got, imo, is that the hoster is blocking certain connections/ports/protocols. if you search the forum we have like a dozen posts exactly the same and only on hosted servers.

I think ownCloud has even a list of hosters that we recommend and we recommend ssh access if using ownCloud.

sorry for the long winded explanation :smiley:
I just did not want to be rude or anything


#7

Hey, i havn’t used the updater app so far but wouldn’t that show the same issue with the apps?


#8

Not to my knowledge, no


#9

But how should the updater app being able to disable the apps and run the update in your explained case?

From what i know you always need to interact manually in the case of this app issue, even if you’re doing the update via the command line or if the updater app would work as expected?


#10

I merely proposed a warning that should occur if a apps check finds apps that could lead to errors during the upgrade


#11

Meanwhile I got SSH access and the hoster had to provide some other missing things (locales were missing…), but the update could be done now using the shell.

Thanks a lot for your help and your thoughts!


#12

Great to hear that :slight_smile: