Update of the locally install 10.3 version fails

Have a local installation of Owncloud 10.3.2 here. When I log in to the browser, I get the message “Updater: A new version is available: ownCloud 10.4.1” under Settings-> General.

When I click on update I get the following message in the browser window: “cURL error 51: SSL: no alternative certificate subject name matches target host name ‘192.x.x.x’”

Unfortunately I am not getting anywhere and I am not an expert, what can I do to update?

Server: ubuntu 18.4
PHP 7.2.24-0ubuntu0.18.04.6

I recommend manual upgrade: https://doc.owncloud.com/server/admin_manual/maintenance/manual_upgrade.html


Thank you for the link, when I run ‘sudo -u www-data php occ upgrade’, I am getting the following message:
‘ownCloud is already latest version’

What’s right browser means there is a new version 10.4.x, console says everything well?


can you paste the output of “occ status” or in your case ‘sudo -u www-data php occ status’?


Hi @mihauck,

$ sudo -u www-data php occ status
  - installed: true
  - first_install_version: unknown
  - version:
  - versionstring: 10.3.2
  - edition: Community

Please read the manual upgrade document carefully, the link was posted before. You have to download a new ownCloud tarball (and don’t forget about the backups). The occ upgrade command is only the very last step.


Hi @cortho,
ok i wonder why it worked with another owncloud cloud on the web server (provider) without problems via browser and locally I have to try tar?

On the other server you probably didn’t have the certificate issue. This is why manual upgrade was suggested here.

So you can

  • either fix your certs
  • or do a manual upgrade

ok thanks, I would prefer the first option, if it is difficult to repair the certificate, I can hope for some help

hello, how should the certificate for the browser update be created or supplemented?

I did a google search for you and found this result: https://www.digitalocean.com/community/tutorials/how-to-create-a-self-signed-ssl-certificate-for-apache-in-ubuntu-18-04

I’d suggest manual upgrade, however.


Thank you very much, I will look at it