Updater claims directories not writable

This is probably a very stupid question, but I just can’t figure it out by myself.

I am trying to run the updater to upgrade from 10.1.0.4 to 10.2.1. However, I am getting the following error:

Checking system health.
The following files and directories are not writable:
/var/www/html/owncloud/core
/var/www/html/owncloud/core/Application.php

Alright, so permissions are not right. Since I am on centos, and the user running my httpd is apache, I ran

sudo chown -R apache:apache /var/www/html/owncloud

Same error. In my desparation, I even ran

sudo chmod -R 777 /var/www/html/owncloud

to make the directory writable to any user. The permissions now look like this:

drwxrwxr-x. 13 apache apache 4096 May 10 09:44 owncloud

but the error persists.

What am I doing wrong here?
Thanks for helping out!

Is SELinux enabled? Can you run ls -alZ on your ownCloud directory?

1 Like

Yes, that was it!
I set the context to httpd_sys_rw_content_t and it seems to work now.

Thanks for helping!

1 Like