Upgrade 10.0.7 schlägt fehl

hosting

#1

Hallo Zusammen,

habe gerade ein Upgrade von Version 10.0.6.1 auf 10.0.7 versucht. Dies über die WEB-GUI. Ist auch alles gut durchgelaufen. Bei der Anmeldung in der WEB-GUI sagte mit dan OC folgendes: Ich möchte doch gerne occ upgrade ausführen.

Was ich dann auch über das Terminal gemacht habe. Dann kam das:

You may use your browser or the occ upgrade command to do the upgrade
2018-04-15T10:23:31+00:00 Set log level to debug
2018-04-15T10:23:31+00:00 Turned on maintenance mode
2018-04-15T10:23:32+00:00 Repair step: Repair MySQL database engine
2018-04-15T10:23:32+00:00 Repair step: Repair MySQL collation
2018-04-15T10:23:32+00:00 Repair info: All tables already have the correct collation -> nothing to do
2018-04-15T10:23:32+00:00 Repair step: Repair SQLite autoincrement
2018-04-15T10:23:32+00:00 Repair step: Repair duplicate entries in oc_lucene_status
2018-04-15T10:23:32+00:00 Repair info: removing duplicate entries from lucene_status
2018-04-15T10:23:32+00:00 Repair step: Upgrade app code from the marketplace
2018-04-15T10:23:32+00:00 Repair warning: Market app is unavailable for updating of apps. Please update manually, see https://doc.owncloud.org/server/9.0/go.php?to=admin-marketplace-apps
2018-04-15T10:23:32+00:00 Repair warning: You have incompatible or missing apps enabled that could not be found or updated via the marketplace.
2018-04-15T10:23:32+00:00 Repair warning: Please install or update the following apps manually or disable them with:
occ app:disable polls
occ app:disable rainloop
2018-04-15T10:23:32+00:00 Repair warning: For manually updating, see https://doc.owncloud.org/server/9.0/go.php?to=admin-marketplace-apps
2018-04-15T10:23:32+00:00 OC\RepairException: Upgrade is not possible
2018-04-15T10:23:32+00:00 Update failed
2018-04-15T10:23:32+00:00 Maintenance mode is kept active
2018-04-15T10:23:32+00:00 Reset log level

Wenn ich das richtig verstehe, ist eine App nicht kompatibel oder? Aber welche (Markettplace)? und warum warnt er mich vor dem Upgrade, wo er alle Apps prüft ob es Probleme gibt? Er hat doch überall einen grünen Haken dran gemacht!

Danke für euere Hilfe :slight_smile:


#2

In dem Log sind doch schon links zu der Doku in dem schon Informationen stehen.

Hast du dir diese durchgelesen und verstehst sie nicht oder hast du sie nicht durchgelesen und hast einfach mal gefragt?


#3

Hallo dmitry,

danke für die Rückfrage. Ne du ich verstehe nicht so genau was ich machen soll, daher habe ich nachgefragt!


#4

Okay, hab gerade auf die Links selbst geklickt und es ist ein Fehler von ownCloud.

Die Links linken zu der 9.0 Doku, und du machst ein Upgrade von 10.0.6 zu 10.0.7 also ist der Link auf jeden Fall falsch. Außerdem linkt der Link zu etwas was entweder verschoben oder umbenannt wurde, weil es eine Umleitung gibt zu der Hauptseite.

Zu deinen Fragen:

Ich kann dir nicht sagen warum, aber du musst halt das tun was da steht:

occ app:disable polls
occ app:disable rainloop

Wenn ich das richtig verstehe, ist eine App nicht kompatibel oder?

Bei einem Upgrade muss man die nicht Core Apps deaktivieren, dazu gehören alle Apps die du nachinstalliert hast. Core Apps sind die Anwendungen die out of the Box kommen.

Aber welche (Markettplace)?

steht da: rainloop, polls

warum warnt er mich vor dem Upgrade, wo er alle Apps prüft ob es Probleme gibt? Er hat doch überall einen grünen Haken dran gemacht!

Das eine hat mit dem anderen glaub ich wenig zu tun. Es wird nicht ein und der selbe Test gemacht und einmal läufts ohne Fehler und ein mal entscheidet ownCloud sich einen Fehler zu schmeißen. So wie ich das sehe wird im ersten Test festgestellt ob du überhaupt in der Lage bist dir den neuen Code zu laden, und ob deine derzeitige ownCloud nicht kaputt ist, dann wird das Upgrade versucht durchzuführen. Wenn das nicht klappt weil du zB 3rd Party apps hast, sagt er dass du auf der Kommando Zeile nochmal ein Upgrade machen sollst. Da hast du nämlich mehr output und gleich die Cahnce die 3td Party Apps zu deaktivieren.

Ich hoffe ich konnte deine Fragen hinreichen beantworten.

Dass der ganze Prozess suboptimal ist verstehe ich und ich versuche daran etwas zu verändern.

Bis dahin - danke dass du uns darauf Aufmerksam gemacht hast.


#5

Hallo dmitry,

ich habe zu danken :slight_smile: Schön das du dir die Sorgen überhaupt anhörst und versucht zu helfen! Ich werde es versuchen die Tage umzusetzen und halte dich auf den laufenden.