Upgrade gives Internal Error 500


#1

Hi all

Recently installed oC version 8.1 in my Qnap NAS TS251+. It all worked well to begin with.
Then I tried to upgrade with the automatic function. Bad choise.
First I saw a two mile long error list, waited 30 minutes looking at the spinning wheel.
Had no other choise than break the "upgrade".
Now I get Internal server error 500 and nothing works.
The owncloud folder permission have changed from "Admin" to httpusr"
Since I do not have any user with that name I guess the upgrade function did that. I can not change back to admin.
Guess i could reinstall it with a higher version but I put in several days of work to configure with many calendars, shares etc.
Very much grateful for any useful tip


#2

I would recommend installing new with a higher version, 10.0.3 is the latest and greatest.


#3

Yes, that is an option but I will likely looese several days of work


#4

You are correct.

I don't know of an option that would export your settings and import it in the new ownCloud. Neither do I know what exactly went wrong with your update, since ownCloud 8.2 is no longer supported, and we recommend using the manual tar ball update.

It would be easier and safer to install fresh, than look for an error, and find a workaround that may or maybe not work.


#5

OK, got you. I really worry about all the information I have saved in the cloud. Is that gone too? I did make an export of the SQL tables and also have a backup from the old owncloud. May be they are not compatible any more.


#6

You can copy everything you have in your data folder, and import it back to the new installation. So you don't lose any files

The database tables may be not compatible from 8.2 to 10.0.3, you are correct there.


#7

Really, that sounds good. i test it for sure