Upgrade OC 8.1.1 to 9.1

My current OC installation is showing as version 8.1.1 and the Admin panel is showing that this is the current version. I tried to manually upgrade to 9.1 using

apt-get update && apt-get install owncloud

After retrieving the packages I get the message
'owncloud is already the newest version.
0 upgraded, 0 newly installed, 0 to remove and 155 not upgraded.'
Does this mean I really have the latest version (and it's just showing an incorrect version number) or is there a problem with my upgrade process?

          PHP Version:

          MySQL Version:


with 8.2 you need to switch repos as stated at various places like:


Make sure that you're doing an supported upgrade path:

8.1.x -> 8.2.x -> 9.0.x -> 9.1.x

by following:


Thanks for the quick response. I didn't get any prompts for the 8.1 to 8.2 upgrade so have missed these. I am catching up now!

My current version is 8.1.1 and the first step of 'upgrading across skipped releases' is "Add the repository of your current version". Where is the repository for 8.1.1 and what is the command line to add this to my Ubuntu sources list?
Thanks again.
I have added
deb http://download.owncloud.org/download/repositories/8.2/Ubuntu_14.04/ / to owncloud.list and owncloud.list.distUpgrade
is this correct to upgrade from 8.1.1 to 8.2?
When I then run 'apt-get install owncloud' I still get the message 'owncloud is already the newest version'.

Please post the output of:

apt-cache policy owncloud

Here you go:

Installed: 8.2.7-2.1
Candidate: 8.2.7-2.1
Version table:
*** 8.2.7-2.1 0
500 http://download.owncloud.org/download/repositories/8.2/Ubuntu_14.04/ Packages
100 /var/lib/dpkg/status
6.0.1+dfsg-1ubuntu1.2 0
500 http://is.archive.ubuntu.com/ubuntu/ trusty-updates/universe amd64 Packages
6.0.1+dfsg-1ubuntu1 0
500 http://is.archive.ubuntu.com/ubuntu/ trusty/universe amd64 Packages
N: Ignoring file 'owncloud.list.save.1' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension
N: Ignoring file 'owncloud.list.save.1' in directory '/etc/apt/sources.list.d/' as it has an invalid filename extension


this here:

means that you have broken your setup somehow in the past (maybe moved stuff from /var/www/owncloud around) as your oC installation is still on 8.1.1. Thats also the reason why you didn't got anything newer then 8.1.1.


  • Make a backup on client-site (files, calendar, contacts)
  • Purge the current installed ownCloud package
  • Remove everything related to ownCloud from your system (including database)
  • Make a complete fresh setup of oC 9.1 from the "stable" repository (see install page on owncloud.org)
  • Sync your files, calendar and contacts back

Oh, that's drastic! Updates were working fine up to 8.1.1 so not sure where things could have gone wrong. Anyway, I'll do as you suggest. Many thanks for your help.

Sorry, something you said prompts one more question. My OC installation is at
not at
Would this have caused a problem with upgrading from 8.1.1 given that it has been fine in the past? There is an owncloud folder in /var/www/owncloud and the version.php file shows:

$OC_Version = array(8,2,7,1);
$OC_VersionString = '8.2.7';
$OC_Edition = '';
$OC_Channel = 'stable';
$OC_VersionCanBeUpgradedFrom = array(8,1);
$OC_Build = '2016-07-18T17:35:54+00:00 3eaa45ddcc61686aa0a4a742c1a00f6ed855697d';

So it looks like my upgrade to 8.2.7 has gone into /var/www/owncloud rather than my live web site at /var/zpanel/hostdata/zadmin/public_html/owncloud_8bit_co/owncloud. Is this recoverable without a completely fresh install?

If you use the packet manager, you have to deal with the directories it uses, you can't just move them around. Not sure, if symlinks could be a viable option.

You can just run regular manual upgrades on /var/zpanel/...

Exactly. Thats also described in the documentation where a big red warning is stating since a longer time:

Do not move the folders provided by these packages after the installation, as this will break updates.

OK, thanks for all your advice. I have now successfully completed a manual upgrade from 8.1.1 to 8.2.7 - two more to go to get up to date!
One final question - I have not used the package manager previously but have used the automatic update wizard from the Admin page. My installation now correctly shows version 8.2.7 on the Admin page but also states, incorrectly, that this is the latest version. How can I get back to having the correct update notifications on the Admin page with the option to manage updates from there?
Many thanks,

Seems 9.0.4 is not provided in the "stable" update channel yet:


but only in the "beta" channel:



OK, manually upgraded to 9.0.4 successfully, thank you, and I can now see the upgrade to 9.1 in the Beta channel.