Upload Button ("+") is missing for a single LDAP user


#1

A single user in a quite large installation does not get the + to upload files in the Browser-Client. I see a http/404 when the Browser tries to get the remote.php wih PROPFIND. When I try to access remote.php as an URI I get the message “This is Webdav…” so the URI kind of works as GET.

The user can login normally. There are no errors in the F12-Debugger of the Browser apart from the 404 mentioned above.

It happens with several browsers. It happens on different PCs.

All the 100s other users can work normally.

I don’t see the account in the log of the server. I only see his IP.

LDAP-Server is a MS-AD.

The data directory looks fine to me.

The version of the server is -10.0.8- update: changed to 10.0.10.4

Any hints?


#2

Hey,

have you considered to update to a recent version first before looking for an issue in an outdated version?


#3

Version is now 10.0.10.4

I tried a maintenance:repair

There is no change to the bug.

some more info:

ldap:check-user reports The user is still available on LDAP.

the log of apache says for this user:

… - - [10/Oct/2018:06:28:09 +0200] “PROPFIND /remote.php/webdav/ HTTP/1.1” 404 798 “-” “Mozilla/5.0 (Windows NT 10.0; WOW64; Trident/7.0; rv:11.0) like Gecko”

for other users:

… - - [10/Oct/2018:07:17:17 +0200] “PROPFIND /remote.php/webdav/ HTTP/1.1” 207 8429 “-” “Mozilla/5.0 (Windows NT 6.3; Win64; x64; rv:62.0) Gecko/20100101 Firefox/62.0”


#4

Have you tried other browsers?

Can it be a browser plugin issue?


#5

We tried the broken account on a PC of a collegue that can use OC -> still broken.

We tried the working account on the “broken PC” -> he can work.

We also tried different browsers -> all the same problem.

I found another account that does not work. Both have in common that they did not use OC for a very long time. So there were some upgrades in the mean time.

I deleted one entry from the users of OC -> Now this one can work.

Now I try to find the difference to the other one that does not work to find the real root cause.


#6

Hey,

could it be possible that either the permissions of this user in the home directory is wrong or that there are some wrong information about the permissions saved within the ownCloud database?

Maybe this could explain the differences between the users?


#7

All data directories have full (rwx) permissions to the user of the web-server (www-data).

I checked the tables of the database and could not find any suspect entries. Could you be more specific about which entries to look at?


#8

Hey,

unfortunately i don’t have any knowledge about ownCloud internals or similar as i’m also just using ownCloud as an “end user” :confused:.

But thinking about your issue the two logical explanations are probably the ones above. Either one of the following is probably the case:

  1. the user don’t have any permissions to write to the filesystem and this ownCloud is hiding the upload button

  2. ownCloud thinks that the user doesn’t have any permissions for uploading files and thus hiding the upload button

As you have verified point 1. probably only the second might be the issue here.


#9

A quick question, since this user has not used ownCloud for a long time, would it not be easier to just create a new account for this user?


#10

This would be the “pragmatic” approach. And I think I will go this way with the other account as well.

But on the other hand: The idea “it might be related to old accounts” is just a guess based on two accounts out of hundreds. So it might be any other root cause as well.

Basically I think OC should drop a note to the user when it is not be able to offer the “+” button. I’d say this is a quite uncommon case. Maybe it would be a good improvement to a future version.


#11

Hey,

i think this could be really something which should be improved. But from my limited experience here at the forums i havn’t seen such suggestions picked up by the ownCloud team. From what i know a request for such improvements needs to be posted at https://github.com/owncloud/core/issues