User_external: disabling logins with '@' does not work any more


#1

Expected behaviour:
login form should prevent user from logging-in when input contains '@'
(it used to work correctly before)

Actual behaviour:
user is logged-in and actually a new user is created (different from the user without @Domain).

All the info is here on GitHub: https://github.com/owncloud/apps/issues/2223

Thanks for help


#2

Hi,

did you have a look at the docs?

I remember there was someone with a similar problem, and he could fix it by adding the "domain" path in the configuration. That prevented ownCloud to create 2 different users for the same account.

https://doc.owncloud.com/server/10.0/admin_manual/configuration/user/user_auth_ftp_smb_imap.html?highlight=imap#imap


#3

Yes, I've had this set-up for a while (the domain parameter added in external plugin), and it does not work. I am able to log-in with the domain (user@domain.test) and new user is created - I can see the new user in "Users" page.

The truth is I am running oc 9.1.6.2, not 10.x - might be problem?


#4

I would try 10.x on a test system and see if the problem is fixed.