Users page hangs when LDAP is enabled

ldap

#1

Hi there,

I'm new to Owncloud forum but I've been using / testing the product for a while now. I always managed to resolve problems by researching however I bumped into this one and I don't seem to find anything relevant on the net.

I've also tried clearing the LDAP configuration and recreate it then upgrade the version (in a cloned test environment) from 9.1.6 to 10.0.2 (latest) version hoping it will resolve the problem.

It has resolved something but caused other issues so I decided to roll back my snapshot on the clone test environment to original 9.1.6

The problem I'm experiencing is with LDAP. The configuration works, talks to our DC and authenticates users with active directory.

However when I go to the Users page in Owncloud it gives me a blank page and with the 'loading' spinning logo until I go to a different page.
This wouldn't be an issue if I didn't have to assign users into local groups.

If I disable LDAP the users page works perfectly fine and I can see all the local users.

Has anyone come across something like that?
The environment only has circa 130 users and the Ubuntu server has enough resources.

I don't know what else I could do sort of rebuilding it to see what happens.
All suggestions are appreciated.

Regards
Gabor


#2

Hi there,

have you tried the user:sync command?

edit: Also, you know you can assign LDAP users to LDAP groups, right?


#3

Hi Dmitry,

Thanks for your response. Yeah, I tried the sync command and yes I am aware I could sync groups from my LDAP server and assign users to that. However I do have a mixed setup where I have local as well as synced LDAP users.

Unfortunately I'm unable to add local users to the synced LDAP groups hence I'm just creating local groups.

Have you got any other suggestions to do by any chance?
Could I be out of resources? ...though it seems like the server is operating normally so I suppose that's not the case.

Regards
Gabor


#4

Hi Gabor,

do you have a log output for me?

It's always better if you have the actual error in front of you, and go from there to fix it.

The log would be at /owncloud/data/owncloud.log